Closed Bug 1805159 Opened 2 years ago Closed 2 years ago

Crash in [@ futex_wait]

Categories

(Core :: Widget: Gtk, defect)

Unspecified
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1801820

People

(Reporter: gsvelto, Unassigned)

Details

(Keywords: crash)

Crash Data

Crash report: https://crash-stats.mozilla.org/report/index/d7c17d48-9073-48bb-bbcf-7b76f0221212

Reason: SIGABRT

Top 10 frames of crashing thread:

0  libc.so.6  futex_wait  /usr/src/debug/glibc/sysdeps/nptl/futex-internal.h:146
0  libc.so.6  __GI___lll_lock_wait  /usr/src/debug/glibc/nptl/lowlevellock.c:49
1  libc.so.6  lll_mutex_lock_optimized  /usr/src/debug/glibc/nptl/pthread_mutex_lock.c:48
1  libc.so.6  __GI___pthread_mutex_lock  /usr/src/debug/glibc/nptl/pthread_mutex_lock.c:93
2  libX11.so.6  _XInternalLockDisplay  /usr/src/debug/libx11/libX11-1.8.2/src/locking.c:526
3  libX11.so.6  _XReadEvents  /usr/src/debug/libx11/libX11-1.8.2/src/xcb_io.c:491
3  libX11.so.6  _XReadEvents  /usr/src/debug/libx11/libX11-1.8.2/src/xcb_io.c:454
4  libX11.so.6  XIfEvent  /usr/src/debug/libx11/libX11-1.8.2/src/IfEvent.c:70
5  libgdk-3.so.0  gdk_x11_get_server_time  /usr/src/debug/gtk3/gtk/gdk/x11/gdkwindow-x11.c:5627
6  libgtk-3.so.0  clipboard_get_timestamp  /usr/src/debug/gtk3/gtk/gtk/gtkclipboard.c:496

This seems to be happening on X11 when copying/pasting text. Here's a few comments:

Crashes when I mark text - but happens randomly. Both when I mark text with mouse, and in textbox with arrowkeys + shift. Sometimes it's often, somtimes not. Doesn't depend on the page I'm on - happens at any site.

Completely froze while editing a facebook comment.

This happens to me when I am using firefox with 2 windows, while navigating/selecting text

This could be related to bug 1802229 as it happens only on X11.

See Also: → 1802229
Status: NEW → RESOLVED
Closed: 2 years ago
Duplicate of bug: 1802229
Resolution: --- → DUPLICATE
See Also: 1802229
Duplicate of bug: 1803592
No longer duplicate of bug: 1802229
Duplicate of bug: 1801820
No longer duplicate of bug: 1803592
You need to log in before you can comment on or make changes to this bug.