Extra blank line before the '-- ' of the signature, and can't be deleted in html compose

RESOLVED WORKSFORME

Status

defect
--
minor
RESOLVED WORKSFORME
17 years ago
11 years ago

People

(Reporter: oliver, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.2) Gecko/20021115
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.2) Gecko/20021115

When you Compose an email, a blank line is added before the '-- \n' of the
signature. 
In the mail window, this blank line is not editable/visible

Reproducible: Always

Steps to Reproduce:
1. Compose an email
2. Sent it
3. Read the email to check the blank line



Expected Results:  
Mozilla should sent the email as displayed in the Compose window
Related: bug 70728, bug 163783
resolving as dup of bug 163433.

*** This bug has been marked as a duplicate of 163433 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
This has nothing to do with POP or IMAP.
Maybe it is related to: bug #70728 or bug #163783

This is how I tested it:
I sent a mail to myself using sendmail and wu-imap. Then I save the email as
.txt in WinXP.

With signature disabled, 1 lines is added at the end.

With signature enabled, 1 lines is added before the signature and 2 lines after
the signature.

I never used POP, so, reverting the dup.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Oliver Schulze L., your report is very confusing.

> I sent a mail to myself using sendmail and wu-imap.
"wu-imap" was the mail client used to receive the mail?  Was Mozilla involved in 
this mail, or not?  If so, did you bypass SMTP (by "using sendmail") to send the 
mail?  I'm assuming you composed this mail with Mozilla, otherwise I can't see 
why you even filed this bug report.

> With signature enabled, 1 lines is added before the signature
Did v. 1.2 not include the sig in the message body when it opened the Compose 
window?

Here's what I did with 1.4b-0527:
Opened a Compose window for a non-sig account.  Addressed it my Unix shell 
account, gave it a subject, and then in the message body typed:
1<cr>2<cr>3
I did not add a third CR, and I could not move the cursor to the line following 
the 3.  I hit the Send button.

Then opened a Compose window for an account with a sig.  Same address and subj, 
the window came up with the sig separator on the second line (first line blank, 
where the cursor was located), followed by three lines of sig.  There was a 
newline after the final sig line, so I could place the cursor immediately below 
the sig.  (This newline was expected, because it is in the sig file.)

I returned the cursor to the top line and typed:
1<cr>2<cr>3
so that the third line of the message was immediately followed by the line with 
the sig separator.  (<cr> = Enter, or Return, or Carriage Return)

I received both emails via POP on the shell account, using the venerable old 
"Berkeley mail" program, and saved them individually to files.  The saved files 
were different by one newline at the end, which corresponds to the newline that 
followed the sig when it was inserted.

No extra lines appeared between the message body and the sig.

Finally, as one more test, I edited the sig file to remove the final newline, 
and opened a new Compose window.  With the edited sig, I could not place the 
cursor on the line following the sig, but only as far as the end of the last 
line.

Are you seeing this same behavior?
If the behavior has changed since 1.2, then this bug should be WorksForMe.

If this behavior is what you've always seen, then this bug is invalid -- 
everything is working exactly as I would expect it to.  In particular, if you 
are complaining about the blank line immediately preceding the sig when the 
compose window is opened, your complaint has no merit -- this is the preferred 
behavior, because most messages are going to have text before the sig, and that 
blank line prevents an extra <cr>.
on comment #3
I still see this issue of the blank linke before the '--' of the signature.
The '--' separator was created to separate the body from the signature, so,
there is no need to add another blank line there.
Let me know if there should be a blank line by RFC or something else.
I sended this email to myself, please look at the empty line before the '--'
characters.
This empty line can not be deleted while composing the email.
Con someone please confirm this bug or issue? Many Thanks
--------------------------------------------------------------------------
Return-Path: <oliver@samera.com.py>
Received: ...
Message-ID: ...
Date: Fri, 26 Dec 2003 13:49:01 -0300
From: "Oliver Schulze L." <oliver@samera.com.py>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b)
Gecko/20031205 Thunderbird/0.4
X-Accept-Language: en-us, en
MIME-Version: 1.0
To: oliver@samera.com.py
Subject: Test for bug #180558
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit

line #1

-- 
Oliver Schulze L.
<oliver@samera.com.py>
This is true for mail composed with the HTML mail composer which is then 
converted to plain text on sending.  Replicated with:
  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031208

When I first looked at this problem in May, I never thought to try the HTML 
composer.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Please note that you can not edit the next line after the line where the string
"line #1" is. This screenshot is from Thunderbird 0.4 but it is the same in
Mozilla 1.6a
Product: MailNews → Core
Severity: normal → minor
Assignee: ducarroz → nobody
QA Contact: esther → composition
Summary: Blank line is added before the '-- ' of the signature → Extra blank line before the '-- ' of the signature, and can't be deleted in html compose
Oliver, is this bug still an issue with current versions of software?  I'm no longer able to reproduce with Thunderbird -- I suspect this was fixed by the patch for bug 144998.
(In reply to comment #8)
> Oliver, is this bug still an issue with current versions of software?  I'm no
> longer able to reproduce with Thunderbird -- I suspect this was fixed by the
> patch for bug 144998.
> 

I still see this issu in Thunderbird 1.5.0.9
You need to start a new email in html in order to reproduce the bug. I still can not delete the blank line before the "-- " of the signature
Not a problem on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007111304 Thunderbird/3.0a1pre ID:2007111304
WFM also XP version 3.0a1pre (2007110302)
Status: NEW → RESOLVED
Closed: 17 years ago12 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.