Popup blocking kills all javascript

RESOLVED DUPLICATE of bug 155351

Status

Camino Graveyard
General
--
major
RESOLVED DUPLICATE of bug 155351
16 years ago
15 years ago

People

(Reporter: Joshua Ochs, Assigned: saari (gone))

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021116 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021116 Chimera/0.6+

Well, after an hour of troubleshooting, I have discovered a *really* annoying
bug in Chimera 0.6 and later. When you enable popup blocking, all JavaScript
appears to fail. For instance, rename your "prefs.js" file (so it doesn't load
any special prefs) and go here:

http://www.info.apple.com/usen/cip/index.html

Select something from the popup list, and it works. Now go into preferences and
turn on popup blocking. Quit and relaunch Chimera, and go to the same site. Now
the popup menu does nothing!

I've traced it to the following line in prefs.js:

user_pref("dom.disable_open_click_delay", 1000);

By default, this line is:

user_pref("dom.disable_open_click_delay", 0);

Reseting it to zero appears to work fine, and still blocks popups. With it at
1000 (which is what the popup code sets it to), it has killed most if not all
Javascript I've tried to use.

Reproducible: Always

Steps to Reproduce:
1. Enable Popup Blocking
2. Attempt to use the menu at http://www.info.apple.com/usen/cip/index.html
(among others)
3. There is no step 3

Actual Results:  
When dom.disable_open_click_delay = 1000, it does nothing.

Expected Results:  
When dom.disable_open_click_delay = 0, it works, and proceeds to the proper
support page.

This happens in both Chimera 0.6 and nightlies. Classifying as major due to
apparent loss of all JavaScript.

Comment 1

15 years ago
Err... so you moved aside prefs.js only, is it reasonable to expect chimera to
be cool with that? Try this again, but this time, move aside the whole
preferences folder, not just prefs.js. Also make sure chimera is not running
when you do that. It seems like you really monkeyed around to get this bug to
happen.

Comment 2

15 years ago
Confirmed with 1217.
Copy the provided apple URL 

Enable Popup Blocking via the Prefs, no need to play with .js
Open a new page
Paste URL
Menu does not jump when used.
CLOSE the page !!

Disable Popup Blocking
Open a new page
Paste URL
Menu is working

You must close the page, not quit chimera.
If it has worked (PB disabled) and the page is still opened, Enable PB and it
will continue to work. If you close the page and take a new one, it will no more
work.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 155351 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.