link within a page created by a POST, then RELOAD, POST data not resubmitted

RESOLVED FIXED in mozilla1.4beta

Status

()

defect
RESOLVED FIXED
17 years ago
11 years ago

People

(Reporter: nkinkade, Assigned: radha)

Tracking

Trunk
mozilla1.4beta
x86
All
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.2b) Gecko/20021104 Phoenix/0.4
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.2b) Gecko/20021104 Phoenix/0.4

You are viewing a page that was created by a POST method.  You select a link
that references an anchor tag farther down in the same document.  You then
select to RELOAD the document.  The POST data is not resubmitted, even though
you are still viewing the same document.  As a result, any data that was
dependent on the POSTed data is gone, or wrong.

Reproducible: Always

Steps to Reproduce:
1.  Submit an HTML form using POST method.
2.  When viewing the resulting doc, select a link that moves within same doc.
3.  RELOAD the page, posted data is not resubmitted, nor are you presented with
a dialog asking if you would like to resubmit.

Actual Results:  
Since the data was not reposted, or I was not given the option to repost the
data, anything on the current document was dependent on the posted data is
either gone, or wrong.

Expected Results:  
(Phoenix) Since I was still viewing the same document, generated by the same
POST data, the browser should have asked if I would like to repost the form data.
I love this bug report! It's so neat... yes, anyway, I'm seeing this too.
However, it is a Mozilla issue as I'm getting it with Moz as well.
Assignee: blaker → radha
Status: UNCONFIRMED → NEW
Component: General → History: Session
Ever confirmed: true
OS: FreeBSD → All
Product: Phoenix → Browser
QA Contact: asa → claudius
Summary: link within a page created by a POST, then RELOAD, POST data not resubmitted → link within a page created by a POST, then RELOAD, POST data not resubmitted
Version: unspecified → Trunk
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.4beta
The problem being that the original POST went to http://blah.com/page, and then
you click on http://blah.com/page#anchor, and *then* try to reload. 
Guess-at-a-glance: the new session history entry with #anchor does not contain
the original POST data and we just reload using GET.
Save postdata into the session history entry created for a anchor traversal, so
that postdata will be properly reposted on history operations.
Attachment #117925 - Flags: review?(adamlock)
Comment on attachment 117925 [details] [diff] [review]
patch to docshell

r=adamlock
Attachment #117925 - Flags: review?(adamlock) → review+
Attachment #117925 - Flags: superreview?(alecf)
Comment on attachment 117925 [details] [diff] [review]
patch to docshell

I'm going to rename mOSHE and mLSHE at some point.. these names are SO
confusing.. :)

sr=alecf
Attachment #117925 - Flags: superreview?(alecf) → superreview+
The patch was checked in on 2003-03-27.  This bug has been fixed since then.
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
We can almost test this with the test for bug 413310, except that we'd get the re-POST dialog in the success case, and then be stuck.  :(
Flags: in-testsuite?
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.