Mozilla freezes & takes 100% CPU when replying to the attached message

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: francois-xavier_kowalski, Assigned: bugzilla)

Tracking

({hang})

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021017
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021017

When attemting to reply to the attached mail (sent by a Microsoft Outlook
(Express)?)user Mozilla freezes (actually takes ~100 of the CPU).  It needs to
be killed (-TERM is Ok, no need for -KILL).

I encounter this problem both on this Mozilla 1.2b for Linux & on A Mozilla 1.1
for win2k.  Symptom is the same (so is punishment...)

The message I attempt to send is lost.

Reproducible: Always

Steps to Reproduce:
1.[Reply] to the mail attached
2. do some edition (1 char is enough)
3. [Send] or [Save]


Actual Results:  
Whatever the last operation ([Send] or [Save]) is, Mozilla spins at ~100% CPU &
seems frozen from user's perspective.

Expected Results:  
Message should be sent (or saved to the Draft folder)... & Mozilla should not spin.

1)I am using the default Modern Theme
2)My Mozilla was upgraded step by step from 0.9.8 to the current 1.2b
3) No crach occurs (so no TalkBack)
(Reporter)

Comment 1

16 years ago
Created attachment 106657 [details]
Forward (MIME) of the mail that makes Mozilla spin.

Updated

16 years ago
Keywords: hang

Comment 2

16 years ago
Also on 2002-11-18-08 Linux.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
In a debug build, Mozilla loops on the following assertion:
ASSERTION: Infinite loop: can't advance a reading iterator beyond the end of a
string: 'one_hop>0', file ../../../dist/include/string/nsStringIterator.h, line 175
Break: at file ../../../dist/include/string/nsStringIterator.h, line 175

A stacktrace shows:
#0  0x407e9134 in write () from /lib/i686/libc.so.6
#1  0x40370afc in __JCR_LIST__ () from /lib/i686/libpthread.so.0
#2  0x40791a16 in _IO_file_write () from /lib/i686/libc.so.6
#3  0x407910aa in _IO_file_xsputn () from /lib/i686/libc.so.6
#4  0x40772114 in vfprintf () from /lib/i686/libc.so.6
#5  0x40771b36 in vfprintf () from /lib/i686/libc.so.6
#6  0x407772ed in fprintf () from /lib/i686/libc.so.6
#7  0x40294137 in nsDebug::Assertion(char const*, char const*, char const*, int)
(aStr=0xfffffe00 <Address 0xfffffe00 out of bounds>,
    aExpr=0xfffffe00 <Address 0xfffffe00 out of bounds>,
    aFile=0x40059580 "../../../dist/include/string/nsStringIterator.h",
    aLine=175) at nsDebug.cpp:192
#8  0x40055dba in nsReadingIterator<unsigned short>::advance(int) (
    this=0xbfffb108, n=93)
    at ../../../dist/include/string/nsStringIterator.h:192
#9  0x4027c948 in nsAString::FindChar(unsigned short, unsigned) const (
    this=0x2e, aChar=46, aOffset=847) at nsAString.cpp:186
#10 0x40bac357 in mozTXTToHTMLConv::CompleteAbbreviatedURL(unsigned short
const*, int, unsigned, nsString&) (this=0x8ccab68, aInString=0x8ce2798,
    aInLength=754, pos=847, aOutString=@0xbfffb358) at mozTXTToHTMLConv.cpp:160
#11 0x40bacfe8 in mozTXTToHTMLConv::FindURL(unsigned short const*, int,
unsigned, unsigned, nsString&, int&, int&) (this=0x8ccab68, aInString=0x8ccab80,
    aInLength=1765, pos=954, whathasbeendone=2, outputHTML=@0xbfffb4b8,
    replaceBefore=@0xbfffb490, replaceAfter=@0xbfffb48c)
    at mozTXTToHTMLConv.cpp:476
#12 0x40baf5d6 in mozTXTToHTMLConv::ScanTXT(unsigned short const*, int,
unsigned, nsString&) (this=0x8ccab68, aInString=0x8ccab80, aInStringLength=1765,
    whattodo=2, aOutString=@0xbfffb628) at mozTXTToHTMLConv.cpp:1089
#13 0x40bafb02 in mozTXTToHTMLConv::ScanHTML(nsString&, unsigned, nsString&) (
    this=0x8ccab68, aInString=@0xbfffb618, whattodo=2, aOutString=@0xbfffb628)
    at mozTXTToHTMLConv.cpp:1186
#14 0x40baff21 in mozTXTToHTMLConv::ScanHTML(unsigned short const*, unsigned,
unsigned short**) (this=0xfffffe00, text=0xbfffb628, whattodo=4294966784,
    _retval=0xaa) at mozTXTToHTMLConv.cpp:1282
#15 0x43b75698 in nsMsgComposeAndSend::GetBodyFromEditor() (this=0x8cc3c80)
    at nsMsgSend.cpp:1647
#16 0x43b7a1ae in nsMsgComposeAndSend::Init(nsIMsgIdentity*, nsMsgCompFields*,
nsFileSpec*, int, int, int, nsIMsgDBHdr*, char const*, char const*, unsigned,
nsMsgAttachmentData const*, nsMsgAttachedFile const*, char const*) (
    this=0xbfffb618, aUserIdentity=0xfffffe00, fields=0x8782b68,
    sendFileSpec=0x0, digest_p=-512, dont_deliver_p=-512, mode=-512,
    msgToReplace=0xfffffe00,
    attachment1 [details] [diff] [review]_type=0xfffffe00 <Address 0xfffffe00 out of bounds>,
    attachment1 [details] [diff] [review]_body=0xfffffe00 <Address 0xfffffe00 out of bounds>,
    attachment1 [details] [diff] [review]_body_length=4294966784, attachments=0xfffffe00,
    preloaded_attachments=0xfffffe00,
    password=0xfffffe00 <Address 0xfffffe00 out of bounds>)
    at nsMsgSend.cpp:3048
#17 0x43b7d21f in nsMsgComposeAndSend::CreateAndSendMessage(nsIEditor*,
nsIMsgIdentity*, nsIMsgCompFields*, int, int, int, nsIMsgDBHdr*, char const*,
char const*, unsigned, nsMsgAttachmentData const*, nsMsgAttachedFile const*,
void*, nsIDOMWindowInternal*, nsIMsgProgress*, nsIMsgSendListener*, char const*) (
    this=0xbfffb618, aEditor=0x89def60, aUserIdentity=0xfffffe00,
    fields=0xfffffe00, digest_p=-512, dont_deliver_p=-512, mode=4,
    msgToReplace=0xfffffe00,
    attachment1 [details] [diff] [review]_type=0xfffffe00 <Address 0xfffffe00 out of bounds>,
    attachment1 [details] [diff] [review]_body=0xbfffb628 "(Ð,@\bªÍ\b\235\f", attachment1 [details] [diff] [review]_body_length=0,
    attachments=0xfffffe00, preloaded_attachments=0xfffffe00, relatedPart=0x0,
    parentWindow=0xfffffe00, progress=0xfffffe00, aListener=0xfffffe00,
    password=0xfffffe00 <Address 0xfffffe00 out of bounds>)
    at nsMsgSend.cpp:3859
#18 0x43bbf094 in nsMsgCompose::_SendMsg(int, nsIMsgIdentity*, int) (
    this=0x8bd65c0, deliverMode=4, identity=0x43a29550, entityConversionDone=0)
    at nsMsgCompose.cpp:923
#19 0x43bbf5b1 in nsMsgCompose::SendMsg(int, nsIMsgIdentity*, nsIMsgProgress*)
    (this=0x8bd65c0, deliverMode=4, identity=0xfffffe00, progress=0x8ba4e20)
    at nsMsgCompose.cpp:1054
#20 0x40272f67 in XPTC_InvokeByIndex ()
   from /storage/src/mozilla/dist/bin/libxpcom.so
#21 0x40936ea1 in XPCWrappedNative::CallMethod(XPCCallContext&,
XPCWrappedNative::CallMode) (ccx=@0xbfffc17c, mode=CALL_METHOD) at
xpcwrappednative.cpp:2015
#22 0x4093f1cc in XPC_WN_CallMethod (cx=0x871daf0, obj=0xfffffe00,
    argc=4294966784, argv=0xbfffc174, vp=0xfffffe00)
    at xpcwrappednativejsops.cpp:1283
#23 0x400cc006 in js_Invoke (cx=0x871daf0, argc=3, flags=0) at jsinterp.c:839
#24 0x400d892c in js_Interpret (cx=0x871daf0, result=0xbfffc618)
    at jsinterp.c:2803
#25 0x400cc242 in js_Invoke (cx=0x871daf0, argc=1, flags=2) at jsinterp.c:856
#26 0x409301c2 in nsXPCWrappedJSClass::CallMethod(nsXPCWrappedJS*, unsigned
short, nsXPTMethodInfo const*, nsXPTCMiniVariant*) (this=0x4362f640,
    wrapper=0xfffffe00, methodIndex=5, info=0x8215338, nativeParams=0xbfffcccc)
    at xpcwrappedjsclass.cpp:1200
#27 0x40929db7 in nsXPCWrappedJS::CallMethod(unsigned short, nsXPTMethodInfo
const*, nsXPTCMiniVariant*) (this=0x89f2960, methodIndex=5, info=0xfffffe00,
    params=0xfffffe00) at xpcwrappedjs.cpp:429
#28 0x40273ba6 in PrepareAndDispatch (methodIndex=144648544, self=0x89f2960,
    args=0x5) at xptcstubs_gcc_x86_unix.cpp:100
#29 0x40272f67 in XPTC_InvokeByIndex ()
   from /storage/src/mozilla/dist/bin/libxpcom.so
#30 0x40936ea1 in XPCWrappedNative::CallMethod(XPCCallContext&,
XPCWrappedNative::CallMode) (ccx=@0xbfffd0c0, mode=CALL_METHOD) at
xpcwrappednative.cpp:2015
#31 0x4093f1cc in XPC_WN_CallMethod (cx=0x871daf0, obj=0xfffffe00,
    argc=4294966784, argv=0xbfffd0b8, vp=0xfffffe00)
    at xpcwrappednativejsops.cpp:1283
#32 0x400cc006 in js_Invoke (cx=0x871daf0, argc=1, flags=0) at jsinterp.c:839
#33 0x400d892c in js_Interpret (cx=0x871daf0, result=0xbfffd55c)
    at jsinterp.c:2803
#34 0x400cc242 in js_Invoke (cx=0x871daf0, argc=1, flags=2) at jsinterp.c:856
#35 0x400cc6e3 in js_InternalInvoke (cx=0x871daf0, obj=0xfffffe00, fval=-512,
    flags=2, argc=2, argv=0xbfffd7fc, rval=0xfffffe00) at jsinterp.c:931
#36 0x400a2d7d in JS_CallFunctionValue (cx=0x871daf0, obj=0xfffffe00,
    fval=-512, argc=4294966784, argv=0xfffffe00, rval=0xfffffe00)
    at jsapi.c:3431
#37 0x41f9c28f in nsJSContext::CallEventHandler(void*, void*, unsigned, void*,
int*, int) (this=0x871daf0, aTarget=0x8967cc0, aHandler=0x8967cd0,
    argc=4294966784, argv=0xfffffe00, aBoolResult=0xbfffd7e0,
    aReverseReturnResult=0) at nsJSEnvironment.cpp:1040
#38 0x42009f39 in nsJSEventListener::HandleEvent(nsIDOMEvent*) (
    this=0x8a43f10, aEvent=0x43a32028) at nsJSEventListener.cpp:181
#39 0x40f0a33b in nsEventListenerManager::HandleEventSubType(nsListenerStruct*,
nsIDOMEvent*, nsIDOMEventTarget*, unsigned, unsigned) (this=0xaa,
    aListenerStruct=0x8a46e68, aDOMEvent=0x43a32028, aCurrentTarget=0x89eac78,
    aSubType=8, aPhaseFlags=4294966784) at nsEventListenerManager.cpp:1219
#40 0x40f0b00f in nsEventListenerManager::HandleEvent(nsIPresContext*, nsEvent*,
nsIDOMEvent**, nsIDOMEventTarget*, unsigned, nsEventStatus*) (this=0x8a46df8,
    aPresContext=0xbfffd6f0, aEvent=0xbfffe4d0, aDOMEvent=0xbfffdffc,
    aCurrentTarget=0x89eac78, aFlags=141679344, aEventStatus=0xbfffe3bc)
    at nsEventListenerManager.cpp:2218
#41 0x411149bd in nsXULElement::HandleDOMEvent(nsIPresContext*, nsEvent*,
nsIDOMEvent**, unsigned, nsEventStatus*) (this=0x8a46dc0, aPresContext=0x89f6dd8,
    aEvent=0xbfffe4d0, aDOMEvent=0xbfffdffc, aFlags=141679344,
    aEventStatus=0xbfffe3bc) at nsXULElement.cpp:3399
#42 0x42b625b0 in PresShell::HandleDOMEventWithTarget(nsIContent*, nsEvent*,
nsEventStatus*) (this=0x89f7820, aTargetContent=0x8a46dc0, aEvent=0xfffffe00,
    aStatus=0xfffffe00) at nsPresShell.cpp:6274
#43 0x42c5e3e6 in nsButtonBoxFrame::MouseClicked(nsIPresContext*, nsGUIEvent*)
    (this=0x8b09d08, aPresContext=0x89f6dd8, aEvent=0x8a46dc0)
    at nsButtonBoxFrame.cpp:196
#44 0x42c5de44 in nsButtonBoxFrame::HandleEvent(nsIPresContext*, nsGUIEvent*,
nsEventStatus*) (this=0x413411c8, aPresContext=0x89f6dd8, aEvent=0x8a46dc0,
    aEventStatus=0xfffffe00) at nsButtonBoxFrame.cpp:122
#45 0x42b62299 in PresShell::HandleEventInternal(nsEvent*, nsIView*, unsigned,
nsEventStatus*) (this=0x8a46dc0, aEvent=0xbfffe7b0, aView=0x0, aFlags=513,
    aStatus=0xbfffec10) at nsPresShell.cpp:6242
#46 0x42b62125 in PresShell::HandleEventWithTarget(nsEvent*, nsIFrame*,
nsIContent*, unsigned, nsEventStatus*) (this=0x413411c8, aEvent=0xfffffe00,
    aFrame=0xfffffe00, aContent=0xfffffe00, aFlags=4294966784,
    aStatus=0xfffffe00) at nsPresShell.cpp:6180
#47 0x40f219f1 in nsEventStateManager::CheckForAndDispatchClick(nsIPresContext*,
nsMouseEvent*, nsEventStatus*) (this=0x8a73f30, aPresContext=0xaa,
    aEvent=0x413411c8, aStatus=0xbfffec10) at nsEventStateManager.cpp:2875
#48 0x40f1e858 in nsEventStateManager::PostHandleEvent(nsIPresContext*,
nsEvent*, nsIFrame*, nsEventStatus*, nsIView*) (this=0x413411c8,
    aPresContext=0x89f6dd8, aEvent=0xbfffeef0, aTargetFrame=0x8b09d08,
    aStatus=0xbfffec10, aView=0x8a46dc0) at nsEventStateManager.cpp:1868
#49 0x42b622f9 in PresShell::HandleEventInternal(nsEvent*, nsIView*, unsigned,
nsEventStatus*) (this=0x89f7820, aEvent=0xbfffeef0, aView=0x89f7228,
    aFlags=513, aStatus=0xbfffec10) at nsPresShell.cpp:6247
#50 0x42b617b7 in PresShell::HandleEvent(nsIView*, nsGUIEvent*, nsEventStatus*,
int, int&) (this=0x89f7820, aView=0x89f7228, aEvent=0xbfffeef0,
    aEventStatus=0xbfffec10, aForceHandle=1, aHandled=@0xbfffec0c)
    at nsPresShell.cpp:6134
#51 0x42e1652b in nsViewManager::HandleEvent(nsView*, nsGUIEvent*, int) (
    this=0x89f7060, aView=0x89f7228, aEvent=0xbfffeef0, aCaptured=-512)
    at nsViewManager.cpp:2207
#52 0x42e07ab4 in nsView::HandleEvent(nsViewManager*, nsGUIEvent*, int) (
    this=0xfffffe00, aVM=0xfffffe00, aEvent=0xfffffe00, aCaptured=-512)
    at nsView.cpp:303
#53 0x42e158f9 in nsViewManager::DispatchEvent(nsGUIEvent*, nsEventStatus*) (
    this=0x89f7060, aEvent=0xbfffeef0, aStatus=0xbfffeddc)
    at nsViewManager.cpp:1943
#54 0x42e093eb in HandleEvent (aEvent=0xbfffeef0) at nsView.cpp:80
#55 0x41643edb in nsWidget::DispatchEvent(nsGUIEvent*, nsEventStatus&) (
    this=0x89f7290, aEvent=0xbfffeef0, aStatus=@0xbfffee9c)
    at nsWidget.cpp:1448
#56 0x41643bd3 in nsWidget::DispatchWindowEvent(nsGUIEvent*) (this=0x89f7290,
    event=0xfffffe00) at nsWidget.cpp:1336
#57 0x41643fd4 in nsWidget::DispatchMouseEvent(nsMouseEvent&) (this=0x89f7290,
    aEvent=@0xbfffeef0) at nsWidget.cpp:1475
#58 0x41644b33 in nsWidget::OnButtonReleaseSignal(_GdkEventButton*) (
    this=0xfffffe00, aGdkButtonEvent=0xbfffeef0) at nsWidget.cpp:1937
#59 0x4164b187 in nsWindow::OnButtonReleaseSignal(_GdkEventButton*) (
    this=0x89f7290, aGdkButtonEvent=0xfffffe00) at nsWindow.cpp:1697
#60 0x4164b467 in nsWindow::HandleGDKEvent(_GdkEvent*) (this=0xaa,
    event=0xbfff84f8) at nsWindow.cpp:1796
#61 0x41639e0c in dispatch_superwin_event (event=0x89f7290, window=0x89f7290)
    at nsGtkEventHandler.cpp:1001
#62 0x41639aeb in handle_gdk_event (event=0x8261948, data=0x0)
    at nsGtkEventHandler.cpp:876
#63 0x40509985 in gdk_flush () from /usr/lib/libgdk-1.2.so.0
#64 0x405413ee in g_idle_remove_by_data () from /usr/lib/libglib-1.2.so.0
#65 0x40541199 in g_idle_remove_by_data () from /usr/lib/libglib-1.2.so.0
#66 0x40540174 in g_main_run () from /usr/lib/libglib-1.2.so.0
#67 0x4042af0f in gtk_main () from /usr/lib/libgtk-1.2.so.0
#68 0x4162a0c5 in nsAppShell::Run() (this=0x816bf48) at nsAppShell.cpp:347
#69 0x415c56da in nsAppShellService::Run() (this=0x8173ab0)
    at nsAppShellService.cpp:471
#70 0x0805aca6 in main1 (argc=1, argv=0xbffff494, nativeApp=0xfffffe00)
    at nsAppRunner.cpp:1541
#71 0x08059bb3 in main (argc=1, argv=0x816bf48) at nsAppRunner.cpp:1902
#72 0x40740082 in __libc_start_main () from /lib/i686/libc.so.6
#0  0x40751449 in sigsuspend () from /lib/i686/libc.so.6

Comment 4

16 years ago
Hello.

I'm using mozilla 1.3 alpha build 2002121215 on xp pro sp1.  
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212

I'm getting similar behavior as described here.  If I attempt to send an e-
mail to myself (or anyone else), the cpu goes to 100% upon sending.  If I 
attempt to save a draft of the e-mail, the same thing happens.  I can see that 
the mozilla.exe process simply continues to consume memory as the cpu goes to 
100%.

The build of mozillla was working fine for many days now.  I did not install 
any new applications yesterday when this began happeneing.  In fact, I barely 
touched this machine yesterday for anything other than reading e-mail via 
mozilla.

This same thing happened about 2 weeks ago which prompted me to upgrade from 
mozilla 1.0 (forget build#) to 1.3 alpha.  I tried disabling NAV 2002 
autoprotect but still no luck.  I can probably just uninstall/reinstall 
mozilla, but since this problem happened twice in about 2 weeks, I'd like to 
attempt to help debug it if possible.  I'm not sure where to start though.  I 
have a debug menu in my browser window but not the mail window.  

Can anyone instruct me on how I might help debug this?  This is my first time 
using this forum so any help is greatly appreciated.  Thanks!

Comment 5

16 years ago
I ended up renaming XUL.mfl to something else then this problem went away when 
I restarted mozilla.  I think this file is used for "fast loading" but don't 
really know what that means.  Anyway, sorry about the confusion.  I guess I'll 
just have mozilla recreate this file whenever this 100% cpu problem happens.  
I have the old file saved if that can be of any help.  Thanks!

Comment 6

16 years ago
Hello,
    I just had a similar problem

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

it's been working fine for weeks - no changes (though some network problems) and
suddenly I can't send mail

when I try to send mail mozilla consumes 100% CPUand hangs

based on the previous comment I removed XUL.mfasl and now I can send email again :)

Comment 7

16 years ago
Hrm, so it was a corrupted profile

Worksforme now too, marking as such

Info on how to fix a corrupted profile:
close mozilla including quicklaunch, locate your "corrupt" user profile.
delete 
Profile\xul.mfl

all files in this directorys :
Profile\chrome\*.*
Profile\cache\*.*

You will "only" loose all additional installed Themes and language packs.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.