Closed Bug 1807468 Opened 2 years ago Closed 2 years ago

Flatpak desktop file has duplicate keywords

Categories

(Core :: Widget: Gtk, defect)

Firefox 110
x86_64
Linux
defect

Tracking

()

RESOLVED FIXED
111 Branch
Tracking Status
firefox111 --- fixed

People

(Reporter: bbhtt.zn0i8, Assigned: jokeyrhyme)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/110.0

Steps to reproduce:

The Flatpak desktop file has keywords in two places on line 124 and line 160

https://hg.mozilla.org/mozilla-central/file/tip/taskcluster/docker/firefox-flatpak/org.mozilla.firefox.desktop

This might fail validation which is used by appstream (a warning can be seen while building the flatpak).

$ desktop-file-validate org.mozilla.firefox.desktop 

org.mozilla.firefox.desktop: error: file contains multiple keys named "Keywords" in group "Desktop Entry"

Expected results:

There should be only one keyword key.

Blocks: flatpak
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

The Bugbug bot thinks this bug should belong to the 'Core::Widget: Gtk' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core

Yep, this breaks the desktop-file parsing in my launcher, so I can't start Firefox at all until I've manually edited this .desktop file, and I have to do it everytime Firefox is updated

Please remove the Keywords=web;browser;internet; line (I believe the other Keywords= line is superior due to having translations, etc)

Assignee: nobody → jokeyrhyme
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Okay, well, I seem to have figured out how to submit a patch, yay

We'll see if we can get this approved and merged :)

Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/63f9d0c0025a
de-duplicate Keywords= in flatpak .desktop r=stransky
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 111 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: