ASSERTION: morkObject not thread-safe

RESOLVED DUPLICATE of bug 142123

Status

P4
normal
RESOLVED DUPLICATE of bug 142123
16 years ago
10 years ago

People

(Reporter: smeredith, Assigned: standard8)

Tracking

({assertion})

Trunk
assertion
Bug Flags:
blocking-thunderbird3.0a1 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
When importing an address book, you get a lot of assertions as follows that make
it impossible to complete the operation.

ASSERTION: morkObject not thread-safe: 'owningThread == NS_CurrentThread()' file
mozilla/xpcom/glue/nsDebug.cpp, line 533
mass re-assign.
Assignee: racham → sspitzer
Product: Browser → Seamonkey

Updated

14 years ago
Assignee: sspitzer → mail
(In reply to comment #0)
> When importing an address book, you get a lot of assertions as follows that 
make
> it impossible to complete the operation.
> ASSERTION: morkObject not thread-safe: 'owningThread == NS_CurrentThread()' 
file
> mozilla/xpcom/glue/nsDebug.cpp, line 533

Except on the current trunk, they don't actually stop import working.
Assignee: mail → nobody
Component: Address Book → MailNews: Address Book
OS: Windows XP → All
Product: Mozilla Application Suite → Core
QA Contact: nbaca → addressbook
Hardware: PC → All
(See bug 423539 comment 4.)
Flags: blocking-thunderbird3.0a1?
Keywords: assertion
Not a blocker at this point, since there's no known fallout.  If we're actually violating threadsafety issues, it's conceivable that bad things could be happening, though.  It would be nice to understand more about this.  Mark, can you can have a look since it seems to be related to a patch you landed?
Assignee: nobody → bugzilla
Flags: wanted-thunderbird3.0a1+
Flags: blocking-thunderbird3.0a1?
Flags: blocking-thunderbird3.0a1-
Moving from wanted‑thunderbird3.0a1+ flag to wanted‑thunderbird3.0a2? flag since code for Thunderbird 3 Alpha 1 has been frozen.
Flags: wanted-thunderbird3.0a1+ → wanted-thunderbird3.0a2?
Priority: -- → P4
Moving to bug 142123 as that's the older bug for this.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: wanted-thunderbird3.0a2?
Resolution: --- → DUPLICATE
Duplicate of bug: 142123
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.