When sending a message in plain text, embedded images are lost

VERIFIED DUPLICATE of bug 180997

Status

VERIFIED DUPLICATE of bug 180997
16 years ago
11 years ago

People

(Reporter: bugzilla, Assigned: bugzilla)

Tracking

({dataloss})

Trunk
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

16 years ago
1) Open a message in HTML
2) Insert one or more images
3) go to menu options/format and select plain text only
4) send the message
==>The recipient will receive only the message body converted to plain text. The
image[s] are lost.

This is a scenario which append more than expected, in real life the user does
not change the send format but the message get automatically converted to plain
text because the recipient is listed to accept only plain text. 4.x has the same
issue but I thing we should do a better job. The proposed solution would be to
sent the embedded images as attachment, using the alternative text or the url of
the image as attachment name.

Another problem covered by bug 180991 is that the plain text comversion of
images is poor which make almost impossible for the receiver to guess where
should be the image in the text.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 180997 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Summary: When sendind a message in plain text, embedded images are lost → When sending a message in plain text, embedded images are lost

Comment 2

16 years ago
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.