[Tree]Repeatedly clicking on XUL Tree items crashes Apprunner.exe

RESOLVED WORKSFORME

Status

()

Core
XUL
P3
critical
RESOLVED WORKSFORME
19 years ago
10 years ago

People

(Reporter: jeffrey, Assigned: Alec Flett)

Tracking

({crash})

Trunk
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
I have implemented a Tree in a dialog.  If I repeatedly click on tree cells,
I eventually get an Apprunner.exe crash that kicks me back out to the NT command
prompt that started Apprunner and I see the following:

runtime error R6025
- pure virtual function call

This is not an occasional occurance.  It happens every time. Dialog code is
below. Please contact me if you need more info, i.e., the RDF file, etc.
====================================================================
<?xml version="1.0"?>

<?xml-stylesheet href="chrome://global/skin/" type="text/css"?>

<!DOCTYPE window SYSTEM "chrome://fusion-global/locale/messagingPalette.dtd">

<window title="&messageTo.title;"
  xmlns:html="http://www.w3.org/TR/REC-html40"
  xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
  xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"
  align="vertical" width="309" height="270" onload="InitUsers();">

  <html:script src="chrome://fusion-global/content/RDFUtilities.js"/>
  <html:script src="chrome://fusion-global/content/messaging.js"/>

 	<box style="width: 100%; height: 4px;" ></box>
	<box align="horizontal" flex="1" >
	<box style="width: 12px; height: 100%;" >
	</box>
	<box align="vertical" >

<html:label>&serverHeader;</html:label>
 <html:div id="all-users-div" style="width:150px; height:200px;
background-color: rgb(255,255,255);"  flex="2" >

  <tree id="select-users-tree" ref="NO:UsersRoot" datasources="rdf:null"
  flex="100%" style="height: 100%;">
		<template>
	<rule>
		<treechildren>
		<treeitem uri="..." open="true">
			<treerow >
				<treecell>
					<treeindentation />
						<titledbutton
value="rdf:http://home.netobjects.com/NO-rdf#name" align="left" />
				</treecell>
			</treerow>
		</treeitem>
		</treechildren>
 	</rule>
		</template>

	   <treecol persist="width"
rdf:resource="http://home.netobjects.com/NO-rdf#name" />

    <treechildren ref="NO:UsersRoot" id="NO:UsersRoot"
rdf:containment="http://home.netscape.com/NC-rdf#child" >
		</treechildren>
  </tree>

	</html:div>
	</box>
	<box align="vertical" style="width: 36px;">
	<spring flex="2" />
	<titledbutton style="width: 20px; height: 20px; margin-left: 4px;
margin-right: 4px;" src="chrome://fusion-global/skin/images/arrow_r.gif"/>
	<titledbutton style="width: 20px; height: 20px; margin-left: 4px;
margin-right: 4px;" src="chrome://fusion-global/skin/images/arrow_l.gif"/>
	<spring flex="2" />
	</box>
	<box align="vertical">
	<html:label>&usersHeader;</html:label>
	<html:div style="width: 90px; height: 220px; background-color:
rgb(255,255,255);">

	</html:div>
	</box>
	</box>
 	<box style="width: 100%; height: 4px;" ></box>

	<box align="horizontal" >
	<spring flex="3"/>
	<titledbutton value="OK" align="center" style="width: 70px; height:
12px; "/>
	<titledbutton value="Cancel" align="center" style="width: 70px; height:
12px;" oncommand="window.close();"/>

	<!-- <spring flex="1"/> -->

  </box>
</window>
================================================
(Reporter)

Comment 1

19 years ago
Created attachment 2673 [details]
RDF file for the XUL Tree

Updated

19 years ago
Summary: Repeatedly clicking on XUL Tree items crashes Apprunner.exe → [Tree]Repeatedly clicking on XUL Tree items crashes Apprunner.exe

Comment 2

19 years ago
Marking [Tree]

Updated

19 years ago
Assignee: leger → alecf
Target Milestone: M12

Comment 3

19 years ago
Assigning to Alec, I will duplicate on current build if possible.  Setting to
M12 until we know what's causing the crash.

Updated

18 years ago
Severity: major → critical
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 4

18 years ago
selmer - any luck duplicating? I haven't seen this at all.... jeffrey - could
you have possibly been scrolling before this clicking? the scrollbar was pretty
screwed up until the last day or two.

Comment 5

18 years ago
Gak!  I forgot to try to duplicate this because I was so engrossed in the other
bugs.  I'd like to stay on my current track for a bit yet, maybe I can try this
Thr or Fri.

Updated

18 years ago
Component: Browser-General → XUL
QA Contact: leger → ckritzer

Comment 6

18 years ago
Updating QA Contact.
(Reporter)

Comment 7

18 years ago
Alec, Jan, et al, I reproduced this again this morning after getting a note from
Jan asking if I had scrolled before the crash occurred.  Yes, the crash happens
after scrolling this tree.
(Assignee)

Comment 8

18 years ago
Thanks for the updates, Steve and Jeffrey....
(Assignee)

Updated

18 years ago
Target Milestone: M12 → M13

Comment 9

18 years ago
spam: changing qa contact from ckritzer -> paulmac for xul bugs

Comment 10

18 years ago
Created attachment 3446 [details]
Possible alternate occurance of this bug

Comment 11

18 years ago
previous attachment generated by opening newsgroup window and clicking on first
message numerous times.  The crash didn't happen until I closed the newsgroup
window though...

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 12

18 years ago
Jeffrey claims he can't dup this anymore.  I'll file a different bug for the
crash I attached earlier.

Updated

18 years ago
Blocks: 22176

Comment 13

18 years ago
BULK MOVE: Changing component from XUL to XP Toolkit/Widgets: XUL.  XUL 
component will be deleted.
Component: XUL → XP Toolkit/Widgets: XUL

Comment 14

18 years ago
Sorry for the spam. changing qa contact.
QA Contact: paulmac → jrgm

Updated

18 years ago
No longer blocks: 22176

Comment 15

18 years ago
Adding crash keyword
Keywords: crash

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.