Line spacing from HTML compose window lost when converted to plain text

VERIFIED DUPLICATE of bug 165077

Status

MailNews Core
Composition
--
minor
VERIFIED DUPLICATE of bug 165077
16 years ago
10 years ago

People

(Reporter: jonathan.courtney, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.3a) Gecko/20021114
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.3a) Gecko/20021114

When interleaving a reply to quoted mail message in the html composition window,
the editor gives the appearance of a good line spacing between the quoted text
and the new text.  However, this line spacing is lost when the message is
converted to plain text.

For example, say I reply to a message and it appears in quoted form in the html
compose window like this:

~~~~~~~~~~~~~~~~~~
SoAndSo wrote:
| Hello there!
| How are you doing?
| Sincerely, SoAndSo
~~~~~~~~~~~~~~~~~~~~~~

  And then I interleave a reply like this:

~~~~~~~~~~~~~~~~
SoAndSo wrote:
| Hello there!
  Hi!
| How are you doing?
  Doing well!  How are you?
~~~~~~~~~~~~~~~~~

  In the html compose window, there appears to be a good deal of line spacing
between the interleaved lines.  The appearance looks as if an extra newline has
been added, as if:

~~~~~~~~~~~~~~~~~
| Hello there!

  Hi!
~~~~~~~~~~~~~~~~~

  Which isn't bad, IMO, because it nicely separates the quoted text from the
newly composed text.

  But this apparent spacing isn't preserved when the message is converted to
plain text.  The sent message actually looks like:

~~~~~~~~
| Hello there!
  Hi!
~~~~~~~~

  Which is a bit confusing to read, since the interleaved text is jammed up next
to the quoted text.

  The problem here is that the html compose window is a WYSIWYG editor, but WYSI
not WYG.

  The workaround is to hit two returns when interleaving a response, but this is
unintuitive... it looks like one is adding extra, unwanted space.

Reproducible: Always

Steps to Reproduce:
1. Turn on "quote message when replying"
2. Turn on "compose in html"
3. Set "send format" to "convert to plain text"
4. Reply to a message
5. Position caret in middle of message, hit return, then compose an interleaved
response.
6. Send message
7. View results in Sent folder

Actual Results:  
The line spacing that I saw in the WYSIWYG editor is lost in the plain text output.


Expected Results:  
An extra newline between the quoted text and interleaved text would probably
give an equivalent appearance in the plain text version.

Comment 1

15 years ago
Confirmed using FizzillaMach/2003021203.

     | foo
     
     bar
     
     | baz

becomes

     | foo
     |
     bar
     
     | baz
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Line spacing from html compose window lost when converted to plain text → Line spacing from HTML compose window lost when converted to plain text
Product: MailNews → Core

Comment 2

13 years ago
I believe this bug is a dupe of bug 165077 -- see in particular case (a) of
bug 165077 comment 11.  Jonathan Courtney, if you agree, please mark this as a 
dupe; otherwise, explain what is different in your case from that one.
(Reporter)

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 165077 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.