Closed Bug 1814042 Opened 1 year ago Closed 1 year ago

The variant `wayland` expiration is on 2023-03-01

Categories

(Testing :: General, task)

task

Tracking

(firefox-esr102 unaffected, firefox109 wontfix, firefox110 wontfix, firefox111 fixed)

RESOLVED FIXED
111 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox109 --- wontfix
firefox110 --- wontfix
firefox111 --- fixed

People

(Reporter: release-mgmt-account-bot, Assigned: jmaher)

References

(Blocks 1 open bug)

Details

(Whiteboard: [variant-expiration])

Attachments

(1 file)

If the variant is not used anymore, please drop it from the variants.yml file. If there is a need to keep the variant, please submit a patch to modify the expiration date. Variants will not be scheduled to run after the expiration date.

This bug will be closed automatically once the variant is dropped or the expiration date is updated in the variants.yml file.

More information about variants can be found on Firefox Source Docs.

Note: please do not edit the bug summery or close the bug, it could break the automation.

Blocks: 1725245
Component: Widget: Gtk → General
Product: Core → Testing
Regressed by: 1787329

Set release status flags based on info from the regressing bug 1787329

:jmaher, since you are the author of the regressor, bug 1787329, could you take a look? Also, could you set the severity field?

For more information, please visit auto_nag documentation.

Flags: needinfo?(jmaher)
Keywords: regression

This bug has the keyword regression, so its type should be defect.

Type: task → defect

:stransky- I see you had added a lot of the original Wayland variant logic, but we are not running any tests with this. I know :ahal is working on (or will be soon) a docker wayland image of ubuntu 22.04, so there are resources assigned now to get a formal platform setup for wayland.

Is there usage that you are aware of of the wayland variant? I am happy to keep it if this is being used, otherwise, cleaning up things makes for good code maintenance.

Flags: needinfo?(jmaher) → needinfo?(stransky)
Type: defect → task
Keywords: regression
No longer regressed by: 1787329
See Also: → 1787329

(In reply to Joel Maher ( :jmaher ) (UTC -8) from comment #3)

:stransky- I see you had added a lot of the original Wayland variant logic, but we are not running any tests with this. I know :ahal is working on (or will be soon) a docker wayland image of ubuntu 22.04, so there are resources assigned now to get a formal platform setup for wayland.

Is there usage that you are aware of of the wayland variant? I am happy to keep it if this is being used, otherwise, cleaning up things makes for good code maintenance.

Hello Joel,

wayland variant is not used right now as we're waiting to the new images (ubuntu 22.04). It's no point run Wailand on recent 18.04 images as Wailand is broken there as it's pretty old environment.

So we generally want to run Wayland variants but we can't do that now due to old Ubuntu in Mozilla test suite. That's also block official Wayland support for Mozilla binaries.

Flags: needinfo?(stransky)

Given this- we are blocked on the new native wayland image in ubuntu 22.04. With that we would be looking to run this as a different platform instead of a variant (as it would be a different machine type/image).

I am proposing we remove the variant- right now in terms of priority we are looking to add Ubuntu 22.04 Wayland which will run a subset of tests, then after that is running live, create an ubuntu 22.04 X11 image to replace the existing 18.04 X11 image and tests.

Assignee: nobody → jmaher
Status: NEW → ASSIGNED

:stransky- this is removing the variant from the configs; ideally in the next couple of months there will be a more modern ubuntu and ideally native Wayland available running tests.

Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0c2ecece5e42
Remove Wayland as a test variant in place of an upcoming new platform. r=ahal,ci-and-tooling,aryx
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 111 Branch
Blocks: 1816141
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: