Miss any docs/info about writting own external bugzilla DB access (write) tools

RESOLVED DUPLICATE of bug 122922

Status

()

Bugzilla
Bugzilla-General
--
enhancement
RESOLVED DUPLICATE of bug 122922
15 years ago
5 years ago

People

(Reporter: Marcin Orlowski, Assigned: justdave)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       telnet/80
Build Identifier: 

I would like to access bugzilla database from our automatic reporting software.
But since I'd like to automatically add bugs reports to the DB, I miss any
information about bugzilla internalls that I shall be aware of (i.e. I mostly
mean information about how bugzilla generates bug_id and other IDs to not to
make any duplicates). I don't think I need default API description, but a 1KB
text file with some hints whould help writting own 'wizards' and other tools w/o
need to read whole bugzilla source.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

15 years ago
A note: to simplify the procedure, all bugs would be reported by from the same
bugzilla user account. So I think what I need to know now, is to what to be
aware of to not make any duplicate IDs here and there
For the moment, the documentation constsis of "don't do that". There will
eventually be a perl Bug.pm module you could use, but not in the near future.

Basically, look at teh db schema, and use that. Be prepared to change your
scrips when updating bugzilla versions....
(Reporter)

Comment 3

15 years ago
I've do some tricky test and it seems that simply adding new record with bug_id
MAX(bug_id)+1 and other columns filled with valid content, works w/o harm at the
moment. Any hidden trap *at the moment*?
you sholdn't have to set the bug_id field - it should be autogenerated. Be
careful with table locks + other people doing stuff to bugs.
Bug.pm is the correct route to follow with this for the long term.


*** This bug has been marked as a duplicate of 122922 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.