Closed Bug 1814589 Opened 1 year ago Closed 7 months ago

Enable css-values-4 math functions by default

Categories

(Core :: CSS Parsing and Computation, task)

task

Tracking

()

RESOLVED FIXED
118 Branch
Tracking Status
relnote-firefox --- 118+
firefox118 --- fixed

People

(Reporter: evilpie, Assigned: canadahonk)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-complete)

Attachments

(1 file)

Nightly-only:

  • layout.css.round.enabled,
  • layout.css.mod-rem.enabled
  • layout.css.nan-inf.enabled
  • layout.css.exp.enabled
  • layout.css.abs-sign.enabled
Keywords: dev-doc-needed
Depends on: 1830759
Duplicate of this bug: 1836134
Depends on: 1846808, 1846809
Depends on: 1846811

With recent NaN/inf improvements, we pass 100% of WPTs for many of these now, opened a few sub-bugs for some to try and get them shipped :)
(it is probably better to do many individual bugs(/intents?), even though it is a bit messy/spammy since they are separate prefs?)

No longer depends on: 1846809
Depends on: 1846820
Duplicate of this bug: 1846808
Duplicate of this bug: 1846811
Duplicate of this bug: 1846820

Merged individual bugs for each back into this for one patch (and intent to ship) to enable all.

Specifically enabling these prefs (previously nightly only):

  • layout.css.round.enabled
  • layout.css.mod-rem.enabled
  • layout.css.exp.enabled
  • layout.css.abs-sign.enabled
Assignee: nobody → oj
Status: NEW → ASSIGNED

Release Note Request (optional, but appreciated)
[Why is this notable]: 10 new CSS math functions enabled by default
[Affects Firefox for Android]: Yes
[Suggested wording]: 10 new CSS math functions are now supported: round, mod, rem, pow, sqrt, hypot, log, exp, abs, sign.
[Links (documentation, blog post, etc)]: MDN articles exist for most of these functions, eg abs()

relnote-firefox: --- → ?
Pushed by oj@oojmed.com:
https://hg.mozilla.org/integration/autoland/rev/d84e836e4765
Enable CSS Values 4 math functions by default r=tlouw
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 118 Branch

Added to our 118 Nightly release notes, thanks.

MDN & BCD changes can be tracked in the following GitHub issue: https://github.com/mdn/content/issues/28840

You need to log in before you can comment on or make changes to this bug.