Closed Bug 1814980 Opened 1 year ago Closed 1 year ago

Consider increasing or removing MAX_OMNIBOX_RESULT_COUNT

Categories

(Firefox :: Address Bar, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
111 Branch
Tracking Status
firefox111 --- fixed

People

(Reporter: gregp, Assigned: gregp)

References

(Blocks 1 open bug)

Details

(Keywords: parity-chrome, parity-edge, parity-opera)

Attachments

(1 file)

MAX_OMNIBOX_RESULT_COUNT (formerly known as MAXIMUM_ALLOWED_EXTENSION_MATCHES) has had the same value of 6 since being introduced in bug 1267810. Per bug 1267810 comment 29, this was the same limit Chromium had. Unfortunately, this is no longer the case. Chromium now allows a maximum of 10 visible results.

I think we should align with this change, either by increasing MAX_OMNIBOX_RESULT_COUNT or by removing it. I think we should remove it, as browser.urlbar.maxRichResults already has a default value of 10.

MAX_OMNIBOX_RESULT_COUNT was introduced in bug 1267810 to increase compatibility with Chromium. It no longer serves this purpose as Chromium has since removed its limit of 6 extension-supplied results.

Assignee: nobody → gp3033
Status: NEW → ASSIGNED

Looks like this is all in search code.

Component: General → Search
Product: WebExtensions → Firefox
Component: Search → Address Bar

Thanks, working on it.

Flags: needinfo?(gp3033)
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8dcfab1af109
Remove MAX_OMNIBOX_RESULT_COUNT r=adw
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 111 Branch
Duplicate of this bug: 1375252
You need to log in before you can comment on or make changes to this bug.