<HR> height wrong, etc.

RESOLVED FIXED in mozilla1.0.1

Status

()

Core
Layout
P2
normal
RESOLVED FIXED
19 years ago
15 years ago

People

(Reporter: emk, Assigned: Hixie (not reading bugmail))

Tracking

({css1, html4, testcase})

Trunk
mozilla1.0.1
css1, html4, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Hixie-P4] [fix in hand][CSS1-5.5.24][HTML4-15.3] fixed with bug 38370)

Attachments

(3 attachments)

(Reporter)

Description

19 years ago
Steps to reproduce:
1. Launch mozilla.
2. Go to the following testcase.

Actual result:
HR height is 2px shorter than they should.

Expected result:
HR height should be exactly the same as its width.

I'm using 1999110508 build mozilla.exe on WinNT4 (SP5).
(Reporter)

Comment 1

19 years ago
Created attachment 2690 [details]
Testcase

Comment 2

19 years ago
Created attachment 2698 [details]
screen capture of testcase magnified 4x (1999110608 WinNT)

Comment 3

19 years ago
Confirmed for 1999-11-06-08-M11 nightly binary on Windows NT 4.0sp3.
Attached an enlarged  screencap of the testcase as viewed on same for easier
visibility (some of the edges are faint).

The testcase has 2 <HR>s, one defined as 1em by 1em, the other as 16px by 16px;
both display as only 14px tall. The other two cells in the testcase show
essentially the same style applied to <INPUT> and to <DIV> - both appear
correctly sized.

Updated

19 years ago
Assignee: troy → kipp

Comment 4

18 years ago
Updating to default Layout Assignee...kipp no longer with us :-(

Comment 5

18 years ago
Why are you re-reassing layout bugs? Do NOT touch layout bugs.

The bugs are assigned to Kipp so they can stay neatly organized until we have a
new owner for the block/inline code.

Comment 6

18 years ago
mass moving all Kipp's pre-beta bugs to M15.  Nisheeth and I will
prioritize these and selectively move high-priority bugs into M13 and M14.

Updated

18 years ago
Summary: HR height wrong → [BLOCK] HR height wrong

Comment 7

18 years ago
Adding testcase keyword. Sorry for the spam.
Keywords: testcase
Whiteboard: [TESTCASE]

Comment 8

18 years ago
Adding css1 keyword -- this always was a css bug.

The <HR> elements (cells 1 and 2) are both still a bit squat, and the <INPUT>
(cell 3), sized at the same 1em by 1em as the <DIV> (cell 4) is now noticably
smaller than the <DIV>.

Tested with: 2000-01-28-08-M14 nightly binary on Windows NT 4.0sp3.
Keywords: css1

Comment 9

18 years ago
mine! mine mine mine!  all mine!  whoo-hoo!
Assignee: kipp → buster

Comment 10

18 years ago
moving all buster m15 bugs to m16.
Target Milestone: M15 → M16

Comment 11

18 years ago
bumping up priority, but moving to M17.  That means I can't get to it during 
M16, but once M17 opens it will be a high priority task.
Status: NEW → ASSIGNED
Priority: P3 → P2
Target Milestone: M16 → M17

Comment 12

18 years ago
re-assigning some HR bugs to Rod.  Thanks, Rod!
Assignee: buster → rods
Status: ASSIGNED → NEW

Comment 13

18 years ago
reassigning back to you (buster) its core layout work and it appears that most 
of these aren't HR frame issues, but are block issues
Assignee: rods → buster

Comment 14

18 years ago
mikey: notice in the test case the text control looks like it's too small.  I 
don't think this was the case with heavyweight enders.

Summary: [BLOCK] HR height wrong → [BLOCK] HR height wrong, etc.

Updated

18 years ago
Whiteboard: [TESTCASE]
(Assignee)

Comment 15

18 years ago
Bug 38370 would probably fix this.
Depends on: 38370

Updated

18 years ago
Target Milestone: M17 → Future

Comment 16

18 years ago
accepted and futured, sorry for the spam
Status: NEW → ASSIGNED
(Assignee)

Comment 17

17 years ago
The HR stuff is fixed by the patch to bug 38370. The <input> is still sized
weirdly. The <div> is sized correctly.

If you want the <input> problem to be looked at, please file a separate bug.
This bug is only going to cover the <hr> case.
Assignee: buster → ian
Status: ASSIGNED → NEW
Whiteboard: [fix in hand] fixed with bug 38370
Target Milestone: Future → mozilla1.0
(Assignee)

Updated

17 years ago
Whiteboard: [fix in hand] fixed with bug 38370 → [Hixie-P4] [fix in hand] fixed with bug 38370
(Assignee)

Updated

17 years ago
Summary: [BLOCK] HR height wrong, etc. → <HR> height wrong, etc.

Comment 18

16 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 19

16 years ago
Confirmed using FizzillaCFM/2002070913, except that the first two HRs are taller
than they are wide. Will attach screenshot. Setting All/All.
OS: Windows NT → All
Hardware: PC → All

Comment 20

16 years ago
Created attachment 90924 [details]
Screenshot of testcase in FizzillaCFM/2002070913
Keywords: html4
Whiteboard: [Hixie-P4] [fix in hand] fixed with bug 38370 → [Hixie-P4] [fix in hand][CSS1-5.5.24][HTML4-15.3] fixed with bug 38370
The <input> behavior is purposeful (testcase is in quirks mode, after all --
testing standards in quirks mode is a bad proposition).

The <hr> behavior is fixed by the patch that landed in bug 38370.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.