partly transparent image as table background draws random pixels

VERIFIED DUPLICATE of bug 18170

Status

()

P3
normal
VERIFIED DUPLICATE of bug 18170
19 years ago
19 years ago

People

(Reporter: mats, Assigned: kmcclusk)

Tracking

({testcase})

Trunk
x86
Windows 98
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE], URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
TO REPEAT:
1. start mozilla, load the URL or testcase
2. look at the navigation table to the left titled "Hovedmenu"

ACTUAL RESULTS:
The left part of it contains random pixels.

EXPECTED RESULTS:
The left part of it should be a blue striped area (like the page background).

BUILD AND PLATFORM:
Bug occurs in build 1999110508 on Windows 98 SE.

ADDITIONAL INFO:
There is still random pixels after resizing or covering the window.
(Reporter)

Comment 1

19 years ago
Created attachment 2693 [details]
testcase
(Reporter)

Updated

19 years ago
Whiteboard: [TESTCASE]
(Reporter)

Comment 2

19 years ago
Additional info on the testcase: if you remove 1 row the problem disappears.

Updated

19 years ago
Assignee: beard → karnaze
Component: Compositor → HTMLTables

Comment 3

19 years ago
Table rendering?

Updated

19 years ago
Assignee: karnaze → kmcclusk

Comment 4

19 years ago
Kevin, do you have any ideas on what is going on. The area to the far left is
black on my WinNT build (instead of random bits as reported). When I drag a
window over the table the background becomes blue like I think it should.
This leads me to believe that the table painting code is not faulty. Next when I
resize the window, the same incorrect black shows up. Is this a painting
problem. The image on the table seems to provoke this.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 5

19 years ago
This could be related to Patricks change to hold a list of invalid rects
in the ViewManager instead of expanding the invalidated area?. His change
may have uncovered a bug that was masked in the old code which painting too much.
(Assignee)

Updated

19 years ago
Target Milestone: M14
(Assignee)

Comment 6

19 years ago
Setting milestone to M14

Comment 7

19 years ago
See also bug #16100 which is for the same painting issue, but uses
<TD BACKGROUND> in stead of <TABLE BACKGROUND>
(Reporter)

Updated

19 years ago
Summary: Table background messed up → partly transparent image as table background draws random pixels
(Reporter)

Comment 8

19 years ago
Improved Summary.
Bulk moving [testcase] code to new testcase keyword. Sorry for the spam!
Keywords: testcase
(Assignee)

Comment 10

19 years ago
Resorting to the slow blitting code fixes this bug

in nsCSSRendering::PaintBackground.
If I comment force it to do the following slow blitting code by commenting
out the TileImage logic above it works fine.

   // slow blitting, one tile at a time....
      for(y=y0;y<y1;y+=tileHeight){
        for(x=x0;x<x1;x+=tileWidth){
          aRenderingContext.DrawImage(image,x,y,tileWidth,tileHeight);
        }
      }



*** This bug has been marked as a duplicate of 18170 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 11

19 years ago
Marking as verified dup of 18170.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.