Last Comment Bug 18165 - Automatic Standards Compliance Indication
: Automatic Standards Compliance Indication
Status: VERIFIED DUPLICATE of bug 6211
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: P3 enhancement (vote)
: ---
Assigned To: rickg
: gerardok
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-06 13:16 PST by james_keller
Modified: 2002-05-11 09:24 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description james_keller 1999-11-06 13:16:46 PST
I had an idea: What if there was something right on Mozilla's status bar or
something that indicated when a viewing page had problems with it and/or was
non-compliant in a given area.
I'm not thinking so much of the "this page has errors" message, but something
more like W3C's HTML tester that will tell you if it is strict/transitional
HTML4, etc, or wether you've got loads of IE and/or Windows only tags & plugin
dependancies.

If the average user can easily see, when viewing a page, that although it might
look ok to him, the website is non-compliant, they can easily complain to the
webmaster. Same goes for webmasters. If they can just open up mozilla, and it
already tells them if their pages are ok - isn't that a good thing? If i were a
webmaster, I'd like that feature

If a webpage's non-compliance is made more visible to the end user (in an non-
annoying way), it will only help bring the standards issues to the forefront.
Comment 1 leger 1999-11-15 17:52:59 PST
Wow, great idea, but not sure if this is feasible.  Sending to ekrock and rickg
for thoughts.
Comment 2 rickg 1999-11-15 18:06:59 PST
Actually, it's for real -- and we can do it technically. Recently, we switched
viewsource over to being an XML application. One advantage is
that we can easily embed other information, like errors, into the markup that is
displayed only in the viewsource window. It's always been a
"wouldn't this be cool" kind of feature. The hard part is detecting all the
errors, and it just so happens that our DTD's already do that.
Comment 3 leger 1999-11-16 14:05:59 PST
Putting out on M20 for now to get off rickg's blank TM list.
Comment 4 Hixie (not reading bugmail) 2000-04-06 09:04:12 PDT
See also bug 6211.
Comment 5 Christopher Hoess (gone) 2002-05-10 18:48:19 PDT
REMIND is deprecated.
Comment 6 Christopher Hoess (gone) 2002-05-10 18:48:39 PDT

*** This bug has been marked as a duplicate of 6211 ***
Comment 7 Hixie (not reading bugmail) 2002-05-11 09:24:36 PDT
VERIFIED DUPLICATE

Note You need to log in before you can comment on or make changes to this bug.