allow user to alter line spacing to make sites more legible

RESOLVED WORKSFORME

Status

()

Core
Layout
--
enhancement
RESOLVED WORKSFORME
15 years ago
15 years ago

People

(Reporter: Jonadab the Unsightly One (Nathan Eady), Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021121
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021121

Some sites just seem to use too-small spacing between the lines (in extreme
cases, such as MSKB, causing lines to overlap; address in URL field is a more
mundane example), making the content difficult to read.  Increasing the text
zoom doesn't really help much.  

Reproducible: Always

Steps to Reproduce:
1.  Visit a site with poor line spacing.
2.  Wish you could push a button to fix it.
3.  Find no way to do that.
Actual Results:  
Give up and highlight one line at a time, or save the file and view it 
in a text editor.

Expected Results:  
View->Text Zoom->Change Line Spacing

Another example of a site that, due to bad site design, would be more 
legible if Mozilla provided this feature:
http://support.microsoft.com/default.aspx?scid=kb;en-us;271754

I want to make it clear that this is not Mozilla's fault per se, but it
is something for which Mozilla should be able to compensate, for the sake
of the user, who cannot fix the site design.

I'm not stuck on any particular specific UI for this; if it doesn't belong
under Text Zoom, perhaps both Text Zoom and this (and the upcoming Page 
Zoom that includes scaling images) could all be grouped together, or along
those lines.  Whatever.

Comment 1

15 years ago
Looks like bug 159494 dupe to me. If you routinely need access to MSKB, try the
solution in comment 108 there.
> Looks like bug 159494 dupe to me.

The MSKB may have been fixed, but there are a number of sites where the line
spacing is not what a user might like.  Even text that is not overlapping
may be "too close" for some users' eyes.

The workaround in bug 159494 comment 108 is specific not only to a particular
site but to the way that site was constructed at the time the comment was
made.  It would not work in the general case.  This rfe is about the general
ability for users to tweak the line spacing on any site at any time, much
like the text zoom feature.  

I realise it's not a high priority, but I filed it because over time the lack
of this feature has bothered me a several times at various different sites; 
the two examples I gave were only examples.  
Can't you just set line-height in userContent.css?  Adding an extra 
menuitem and submenu to adjust lineheight seems like overkill to me.
We already support this. It's called a user stylesheet.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.