Closed Bug 1820743 Opened 1 year ago Closed 1 year ago

Allow to move unified extensions button on the navbar

Categories

(WebExtensions :: General, enhancement, P3)

enhancement

Tracking

(firefox113 fixed)

RESOLVED FIXED
113 Branch
Tracking Status
firefox113 --- fixed

People

(Reporter: willdurand, Assigned: willdurand)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [addons-jira])

Attachments

(2 files)

This is a first (admittedly small) step towards more customization of the unified extensions UI.

Is anything preventing this patch from moving into testing in Nightly? (As a contributor, I don't have access to Jira to understand what else needs to be decided.)

Pushed by wdurand@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/56de7c6ac457
Allow to move unified extensions button on the navbar. r=rpl
Flags: needinfo?(wdurand)
Pushed by wdurand@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7f365d0974c0
Allow to move unified extensions button on the navbar. r=rpl
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 113 Branch
See Also: → 1824247

In a brief test, this allows moving the button in a similar manner to the non-removable Back button (i.e., only within the main navigation toolbar).

Any chance of uplift to Firefox 112?

(In reply to jscher2000 from comment #7)

Any chance of uplift to Firefox 112?

Maybe? I don't see why not but it'd be good to wait a bit more and make sure nothing is unexpectedly broken in Nightly.

Blocks: 1824247
See Also: 1824247

Comment on attachment 9321579 [details]
Bug 1820743 - Allow to move unified extensions button on the navbar. r?rpl!

Beta/Release Uplift Approval Request

  • User impact if declined: All users see the extensions button. It's hard to assess who really wants/needs to move this extensions button but we've been getting feedback about this button, e.g. it is less customizable than some other parts of the UI. Allowing to move this extensions button is a first (conservative) step in this direction and it'd be nice to offer this small change to all users in Beta.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): It is low because the code change is fairly small (we move the definition of the button into the part of the navbar that allows buttons to be moved). The patch is covered by some automated tests and we didn't notice any regression in Nightly so far.
  • String changes made/needed:
  • Is Android affected?: No
Attachment #9321579 - Flags: approval-mozilla-beta?

Comment on attachment 9321579 [details]
Bug 1820743 - Allow to move unified extensions button on the navbar. r?rpl!

We're unfortunately out of Beta builds for Fx112 this cycle in light of next week's RC. Given that this is an enhancement and the limited time for testing, it's probably best for this to ride 113 to release.

Attachment #9321579 - Flags: approval-mozilla-beta? → approval-mozilla-beta-

Makes sense, thanks!

Is there any way I can move a button back to the UEB once I moved it to the navbar?

I can't seem to find a way to move it even from the Customize mode.

(In reply to Kelimutu [:kiki] from comment #12)

Is there any way I can move a button back to the UEB once I moved it to the navbar?

I can't seem to find a way to move it even from the Customize mode.

You can context-click on the button and uncheck "Pin to Toolbar" I think.

Ah, didn't see that before. That did it, yeah. Thanks!

I am on latest Nightly and Pin to Toolbar does not exist , Pin to Overflow are 'gray'd' out along with Remove from Toolbar.
What am I missing ?

No longer regressions: 1837849
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: