{inc}float jumps after selecting item from drop down form

RESOLVED DUPLICATE of bug 157444

Status

()

Core
Layout: Floats
P3
normal
RESOLVED DUPLICATE of bug 157444
16 years ago
15 years ago

People

(Reporter: David Grant, Unassigned)

Tracking

({regression, testcase})

Trunk
Future
x86
Linux
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021123
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021123

See the URL given above.  This is occured for me in Mozilla 1.1, so I checked in
a nightly build, and it still occurs.

Reproducible: Always

Steps to Reproduce:
1. Go to the URL: http://www.msc-smc.ec.gc.ca/climate/climate_normals/index_e.cfm
2. Your web browser window must be substantially big.  I think it has to be at
least double the width of the visible stuff on that webpage.  I think 1280x1024
17" monitor is what I have, so if you have that or bigger, it should be fine.
3. In the "Province:" drop-down box, select Alberta.
4. Sometimes Alberta won't trigger the bug.  Select British Columbia

Actual Results:  
If you've triggered the bug, you'll see the centre table with the Canadian
Climate Normals up top has now shifted to the right-hand half of the web page
and top-justified, leaving a white gap where it used to be.  If you resize your
Mozilla window, it will move back to where it is supposed to be.  If you leave
your window resized to a smaller size, this bug does not happen.

Expected Results:  
The table should not have jumped when the drop-down list was selected.
(Reporter)

Comment 1

16 years ago
Created attachment 107536 [details]
Screenshot showing table shifted to right-hand side of page

Screenshot
Yep.  Confirmed.  Looks like an incremental reflow problem in tables...
Assignee: form → table
Status: UNCONFIRMED → NEW
Component: Layout: Form Controls → Layout: Tables
Ever confirmed: true
QA Contact: tpreston → amar
Summary: table jump after selecting item from drop down form → {inc}table jump after selecting item from drop down form
(Reporter)

Comment 3

16 years ago
Did you check for a dup on this?  I had no idea what keywords to search for
becuase I have no idea what exactly was causing.  Sometimes summary lines are
rather advanced.  I tried searching for "table jump" and "table jump form" but
didn't find any dups.

Comment 4

16 years ago
Created attachment 107550 [details]
testcase

testcase exhibits the bug with linux trunk build 20021125
select "Alberta" from the drop-down.  The <select> moves up next to the foobar
div.

Comment 5

16 years ago
regression between linux trunk builds 2002042610 and 2002042807
                   linux 1.0 branch builds 20020607 and 20020621
Assignee: table → float
Component: Layout: Tables → Layout: Floats
Keywords: regression, testcase
QA Contact: amar → ian

Updated

16 years ago
Summary: {inc}table jump after selecting item from drop down form → {inc}float jumps after selecting item from drop down form

Comment 6

16 years ago
the window on the trunk looks like bug 138057, but that was not checked into the
branch.

Updated

16 years ago
Priority: -- → P3
Target Milestone: --- → Future
Depends on: 157444

*** This bug has been marked as a duplicate of 157444 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.