search performance in 1.2 is unusable

VERIFIED DUPLICATE of bug 142196

Status

MailNews Core
Database
--
major
VERIFIED DUPLICATE of bug 142196
16 years ago
10 years ago

People

(Reporter: Jeffrey Siegal, Assigned: Bienvenu)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021126

This is a manifestation of bug 180516, the fix for which is not included in 1.2.
 I included a system call trace showing the unnecessary fsync activity and some
other background in bug 180516.  Other mail activities are also affected, but
search appears to be the worst.  Neverthless, mail performance generally is
greatly reduced from 1.1.



Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

16 years ago
Correction: system call trace in bug 182080

Updated

16 years ago
Keywords: perf
(Assignee)

Comment 2

16 years ago
Could you try this in 1.3? I'd need to know that this is fixed in 1.3 in order
to get permission to check the fix that's in 1.3 into 1.2. Thx.
(Assignee)

Comment 3

16 years ago
sorry, 1.2final is done as of today. So I can't fix this for 1.2.  I believe
this is fixed in 1.3 builds, however. Dup'ing against 142196. Again, my apologies.

*** This bug has been marked as a duplicate of 142196 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

16 years ago
In response to comment 2, yes this is fixed in the trunk (I'm assuming that is
what you mean by 1.3, since there is no 1.3 yet), presumably by the fix for bug
180516.

In response to comment 3, this is not a duplicate of bug 142196 in any way I can
see.  I don't fully understand the Mozilla bug workflow process, so maybe I am
out of line by reopening this; if so I apologize.  Finally, I know that 1.2 has
been released; I verified that the problem still exists in 1.2 before opening
this bug.  The purpose, of course, is to make sure it gets fixed in 1.2.1, since
search is unusable in 1.2 for any mailbox of nontrivial size.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Assignee)

Comment 5

16 years ago
well, we don't really file bugs on a particular release of the product and say
that fixing it in a future version doesn't count (if that were the case, we'd
have an enormous number of open bugs for all the .90 and .91 and .92, etc
release), we file bugs on problems, and fix them in whatever release we can. And
I'm not srue there is going to be a 1.21. But if there was, we still would not
re-open this bug. Open bugs are for bugs that still occur on the trunk. There's
going to be a 1.3.

The underlying problem that caused bug 142196 also caused this problem, which is
why this works on the trunk (I think of every trunk build as the current 1.3
build - I didn't mean the released 1.3 build, sorry for the confusion.

I could just mark this fixed, since it is fixed in the trunk, but that would be
taking credit for fixing two bugs when I really only fixed one bug. So I'm going
to re-dup it.

*** This bug has been marked as a duplicate of 142196 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 6

15 years ago
marking verified 
Status: RESOLVED → VERIFIED
QA Contact: gayatri → laurel
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.