After complete Mozilla 1.2 installation not all components can be started

RESOLVED DUPLICATE of bug 144027

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 144027
15 years ago
13 years ago

People

(Reporter: Victor Pavlushkov, Assigned: asa)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: http://ftp.mozilla.org/pub/mozilla/releases/mozilla1.2/mozilla-win32-1.2-installer.exe

Up to now I was using Mozilla 1.1(stable) and tried to update it up to
1.2(stable) today. The installation was done in a new directory according to
recommendations. Once Mozilla is installed it starts the browser, catches all
bookmarks, but theme (Orbit 3+1 1.x 0.0.6.2) was missing and what is much more
important is that none of other compenents (mail/news composer, address book,
IRC Chat) wanted to be started. Mozilla tries to do something but that gives up
without any message. This happens regardless I did it via small icons in the
bottom or through "windows" ->... Restart of the computer did not help. Attempt
with another installer "talkback enabled Net Installer .exe" leads to the same
result.

Reproducible: Always

Steps to Reproduce:
1. Download an installer for Mozilla 1.2 (Windows 32)
2. Install it to the directory different to the one with Mozilla 1.1
3. Start the newer version of Mozilla
4. Try to open Address Book, Mail/News composer or IRC Chat

Actual Results:  
For a several seconds the Windows pointer turnes to be a clock (Windows feature)
and the Task Manager shows that the processer becomes buzy becoause of Mozilla.
Then everything stops as you did not try to open an application. No message appears.

Expected Results:  
Either open a Mozilla component or show a message with the reason why it is
impossible.

Comment 1

15 years ago
Does this still happen with a new profile? This sort of thing sometimes happens
if your profile gets accidentally munged. 
If a new profile works, can you please delete all files in Profile/Chrome/*.*
(You will loose all additional Themes and language packs)

The old Orbit doesn't appear because you need an updated version..

Comment 3

15 years ago
I had the same thing happen (went from moz1.1 to moz1.2 and now nothing comes up
except the first browser window). I can't bring up Profile Manager either to try
creating a new profile.

Comment 4

15 years ago
Yes I was able to 'fix' this by creating a new profile.  In order to create a
new file I closed Mozilla (the one browser window that would come up) and then I
had to go to the Windows2000 task list and kill the mozilla.exe process that was
still running (and I don't have it quick launched or in the system tray). After
that I was able to bring up Profile Manager from the Start->Program
Files->Mozilla menu.

Since I couldn't get 'Manage Bookmarks' to come up under my default profile I
wasn't able to export the latest bookmark file so I could import to the new
profile. But oh well, I had most of them in an older export file. Somehow it did
keep my mail settings though. Not sure how or why. I actually created and
deleted profiles several times to finally get this to work because of problems I
was having setting the 'Personal Toolbar' in the bookmarks I imported from the
older file.

Comment 5

15 years ago
I think (although I may be wrong) that it's generally considered harmless to
copy the bookmarks.htm file from one profile to another directly.
For win 9x (and hence NT, I assume) the profiles are, by default in
windows\Application Data\Mozilla\Profiles\(User Name)\(random string).slt - the
chache directory under Edit-Preferences-Advanced-Cache should confirm this
(although maybe not if you changed the cache directory in the past).
(Reporter)

Comment 6

15 years ago
It works now! Thank you, guys!
What I did is I removed both "chrome" directories from my personal profile as
well as from "Program files/Mozilla 1.1" directory and performed the
installation one more time. Creation of a new profile was not required.  

*** This bug has been marked as a duplicate of 144027 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.