Sporadic crash after printing http://www.wenxuecity.com

RESOLVED FIXED

Status

RESOLVED FIXED
16 years ago
11 years ago

People

(Reporter: roland.mainz, Assigned: asa)

Tracking

({crash})

Trunk
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

16 years ago
2002-11-21-08-trunk debug build on Solaris 2.7/SPARC, build with Sun Workshop 7
- I am crashing like this after printing http://www.wenxuecity.com
-- snip --
WARNING: empty damage rect: update caller to avoid fcn call overhead, file
../../../../../../../../../home/mozilla/src/2002-11-21-08-trunk/mozilla/layout/html/base/src/nsFrame.cpp,
line 2531
WARNING: empty damage rect: update caller to avoid fcn call overhead, file
../../../../../../../../../home/mozilla/src/2002-11-21-08-trunk/mozilla/layout/html/base/src/nsFrame.cpp,
line 2531
WARNING: empty damage rect: update caller to avoid fcn call overhead, file
../../../../../../../../../home/mozilla/src/2002-11-21-08-trunk/mozilla/layout/html/base/src/nsFrame.cpp,
line 2531
WARNING: empty damage rect: update caller to avoid fcn call overhead, file
../../../../../../../../../home/mozilla/src/2002-11-21-08-trunk/mozilla/layout/html/base/src/nsFrame.cpp,
line 2531
t@1 (l@1) signal BUS (invalid address alignment) in
nsImageListener::FrameChanged dbx: warning: can't find file
"/shared/bigtmp2/mozilla/2002-11-21-08-trunk/objdir_ws7_gtk/layout/build/nsImageFrame.o"
dbx: warning: see `help finding-files'
at 0xfb1de828
0xfb1de828: FrameChanged+0x00a4:        ld      [%i5 + 0x180], %i2
dbx: warning: can't find file
"/shared/bigtmp2/mozilla/2002-11-21-08-trunk/objdir_ws7_gtk/modules/libpr0n/build/imgRequestProxy.o"
dbx: warning: can't find file
"/shared/bigtmp2/mozilla/2002-11-21-08-trunk/objdir_ws7_gtk/modules/libpr0n/build/imgRequest.o"
dbx: warning: can't find file
"/shared/bigtmp2/mozilla/2002-11-21-08-trunk/objdir_ws7_gtk/modules/libpr0n/build/imgContainerGIF.o"
dbx: warning: can't find file
"/shared/bigtmp2/mozilla/2002-11-21-08-trunk/objdir_ws7_gtk/xpcom/build/nsTimerImpl.o"
dbx: warning: can't find file
"/shared/bigtmp2/mozilla/2002-11-21-08-trunk/objdir_ws7_gtk/xpcom/build/plevent.o"
dbx: warning: can't find file
"/shared/bigtmp2/mozilla/2002-11-21-08-trunk/objdir_ws7_gtk/xpcom/build/nsEventQueue.o"
dbx: internal warning: Typeid already exists with different name:__1nJnsAString_
or symclass:struct, ignore current
stab:/shared/bigtmp2/mozilla/2002-11-21-08-trunk/objdir_ws7_gtk/dist/bin/components/libwidget_gtk.so:../../../../../../../../home/mozilla/src/2002-11-21-08-trunk/mozilla/widget/src/gtk/nsAppShell.cpp
stab #432 __1nJnsAString_:U(0,337)
Current function is event_processor_callback (optimized)
  199         eventQueue->ProcessPendingEvents();
(dbx) where
current thread: t@1
  [1] nsImageListener::FrameChanged(0xc4c640, 0x807520, 0xc68818, 0xb5bd78,
0xffbeeae4, 0xdadadada), at 0xfb1de828
  [2] imgRequestProxy::FrameChanged(0xe22f48, 0x807520, 0xb5bd78, 0xffbeeae4,
0xc4c640, 0xfb1de784), at 0xfbca588c
  [3] imgRequest::FrameChanged(0x8adf38, 0x807520, 0x1, 0xb5bd78, 0xffbeeae4,
0xffbeea14), at 0xfbca00ec
  [4] imgContainerGIF::Notify(0x807520, 0xffbeeadc, 0x807598, 0x1, 0x807594,
0xffbeeb0c), at 0xfbcac9e0
  [5] nsTimerImpl::Fire(0xc0d640, 0x1, 0x1, 0xff17dc24, 0xff16f54c, 0x2cc8), at
0xff08a5c4
  [6] handleTimerEvent(0xce8e48, 0x15e8, 0xe4eb0, 0xff13fb11, 0xff16f54c,
0xff17dc20), at 0xff08a7b0
  [7] PL_HandleEvent(0xce8e48, 0xff08a690, 0xd00e80, 0x1, 0x0, 0xce8e48), at
0xff080010
  [8] PL_ProcessPendingEvents(0xc7210, 0xf0430, 0x5, 0xff15aacc, 0xff15aab4,
0xff17d8d0), at 0xff07fe48
  [9] nsEventQueueImpl::ProcessPendingEvents(0xc71e0, 0x0, 0xed45c, 0x0, 0x0,
0x80004000), at 0xff082150
=>[10] event_processor_callback(data = ???, source = ???, condition = ???)
(optimized), at 0xfc627eac (line ~199) in "nsAppShell.cpp"
  [11] our_gdk_io_invoke(source = ???, condition = ???, data = ???) (optimized),
at 0xfc62797c (line ~76) in "nsAppShell.cpp"
dbx: warning: can't find file
"/home/gisburn/package-builds/glib/glib-1.2.8/objdir/giounix.lo"
  [12] g_io_unix_dispatch(0x2fc790, 0xffbeef68, 0x2472f8, 0x0, 0x0, 0xffbeeed0),
at 0xfe7b2dc8
dbx: warning: can't find file
"/home/gisburn/package-builds/glib/glib-1.2.8/objdir/gmain.lo"
  [13] g_main_dispatch(0xffbeef68, 0x15a920, 0x1, 0x0, 0x0, 0x0), at 0xfe7b6dc8
  [14] g_main_iterate(0x1, 0x1, 0x5, 0xff3e4270, 0xfc61aa05, 0x18), at
0xfe7b7bcc
  [15] g_main_run(0x2f6f98, 0x2f6f98, 0x1, 0xfc69ca64, 0xfc69ca68, 0x111fac), at
0xfe7b7f64
dbx: warning: can't find file
"/home/gisburn/package-builds/gtk+/gtk+-1.2.8/objdir/gtk/gtkmain.lo"
  [16] gtk_main(0xc71e0, 0xa0678, 0xffbef044, 0xffbef048, 0x0, 0xfc62841c), at
0xfe9d60a0
  [17] nsAppShell::Run(this = ???) (optimized), at 0xfc628370 (line ~347) in
"nsAppShell.cpp"
  [18] nsAppShellService::Run(this = ???) (optimized), at 0xfc731c4c (line ~471)
in "nsAppShellService.cpp"
  [19] main1(argc = ???, argv = ???, nativeApp = ???) (optimized), at 0x1a44c
(line ~1541) in "nsAppRunner.cpp"
  [20] main(argc = ???, argv = ???) (optimized), at 0x1ae60 (line ~1902) in
"nsAppRunner.cpp"
-- snip --

Note that the print job has been completed at the time the crash occurs (quiz is
if this really a "Printing" bug then... ;-/) ...
The same crash occurs on Win32. See TB14455909 (1.2b) and TB14455094 (1.2 final)

Stack from TB14455909:

nsImageFrame::FrameChanged
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsImageFrame.cpp, line 736]
nsImageListener::FrameChanged
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsImageFrame.cpp, line 2419]
imgRequestProxy::FrameChanged
[c:/builds/seamonkey/mozilla/modules/libpr0n/src/imgRequestProxy.cpp, line 301]
imgRequest::FrameChanged
[c:/builds/seamonkey/mozilla/modules/libpr0n/src/imgRequest.cpp, line 342]
imgContainerGIF::Notify
[c:/builds/seamonkey/mozilla/modules/libpr0n/decoders/gif/imgContainerGIF.cpp,
line 510]
nsTimerImpl::Fire [c:/builds/seamonkey/mozilla/xpcom/threads/nsTimerImpl.cpp,
line 380]
nsTimerManager::FireNextIdleTimer
[c:/builds/seamonkey/mozilla/xpcom/threads/nsTimerImpl.cpp, line 591]
nsAppShell::Run [c:/builds/seamonkey/mozilla/widget/src/windows/nsAppShell.cpp,
line 173]
nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 472]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1538]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1886]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1906]
WinMainCRTStartup()
KERNEL32.DLL + 0x17d08 (0x77e97d08) 
OS: Solaris → All
Hardware: Sun → All

Updated

16 years ago
Severity: normal → critical
Keywords: crash
If I set the pref to turn off image animation, there is no crash.
Severity: critical → normal
http://lxr.mozilla.org/seamonkey/source/content/base/src/nsPrintEngine.cpp#2789

Animation is turned off when printing (as you would expect) but maybe something
is turning it back on again?
duping based on the stacks, please reopen if you disagree but don't kill me.
Thanks


*** This bug has been marked as a duplicate of 182063 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
OK, I won't kill you ;-)

I am reopening because I think the identical stacks are the same symptom caused
by different problems, and here there is probably a simpler solution, if what I
said in comment #3 is correct.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Very similar crash when closing Print Preview. This may be just a dupe of bug 85227.
sorry for the typo and the spam: this may be a dupe of bug 2586.
One place where the image animation mode might be being reset is
http://lxr.mozilla.org/seamonkey/source/layout/base/src/nsPresContext.cpp#682
Created attachment 107643 [details] [diff] [review]
Patch v.0

First pass at a patch. Some comments would probably be a good addition.
Created attachment 107651 [details] [diff] [review]
Patch with some comments
Attachment #107643 - Attachment is obsolete: true

Updated

16 years ago
Attachment #107651 - Flags: review?(rods)

Comment 11

16 years ago
Comment on attachment 107651 [details] [diff] [review]
Patch with some comments

r=rod
Attachment #107651 - Flags: review?(rods) → review+

Updated

16 years ago
Attachment #107651 - Flags: superreview?(roc+moz)
Comment on attachment 107651 [details] [diff] [review]
Patch with some comments

sr=roc+moz
Attachment #107651 - Flags: superreview?(roc+moz) → superreview+
Fix checked in.
really marking FIXED
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey

Updated

11 years ago
Depends on: 192631
You need to log in before you can comment on or make changes to this bug.