Closed Bug 1824744 Opened 1 year ago Closed 11 months ago

Update our in-tree ICU to 73

Categories

(Core :: Internationalization, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
115 Branch
Tracking Status
firefox113 --- wontfix
firefox114 --- wontfix
firefox115 --- fixed

People

(Reporter: anba, Assigned: anba)

References

Details

Attachments

(12 files, 11 obsolete files)

48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review

Also updates to CLDR 43 and brings various bug fixes and improvements.

Release notes: https://icu.unicode.org/download/73

Remove no longer needed backports for ICU-22198, ICU-22206, and CLDR-16399.

Update WASI patch to apply cleanly on ICU 73.

  • Update the URL because the "core.zip" is no longer present.
  • Add code to remove redundant language mappings.

Depends on D176265

No code changes, only updates the CLDR version number.

Depends on D176266

No code changes, only updates the download URL.

Depends on D176267

UNUM_APPROXIMATELY_SIGN_FIELD is no longer a draft API.

Depends on D176268

ICU 73 improved the memory use of the date-time formatter, so let's update our
estimated memory use constants.

DateTimeFormat (UDateFormat):

  • Max-memory reduced to 72440 bytes. (99th percentile use 27340 bytes)

DateTimeFormat (UDateFormat+UDateIntervalFormat):

  • Max-memory increased to 175646 bytes. (99th percentile use 87054 bytes)

NumberFormat (UNumberRangeFormatter):

  • Max-memory increased to 19894 bytes. (99th percentile use 19888 bytes)

RelativeTimeFormat:

  • Max-memory reduced to 8188 bytes. (99th percentile use 8185 bytes)

Depends on D176273

Attachment #9335977 - Attachment is obsolete: true
Attachment #9335978 - Attachment is obsolete: true
Attachment #9335979 - Attachment is obsolete: true
Attachment #9335980 - Attachment is obsolete: true
Attachment #9335981 - Attachment is obsolete: true
Attachment #9335982 - Attachment is obsolete: true
Attachment #9335983 - Attachment is obsolete: true
Attachment #9335984 - Attachment is obsolete: true
Attachment #9335985 - Attachment is obsolete: true
Attachment #9335986 - Attachment is obsolete: true
Attachment #9335988 - Attachment is obsolete: true
Pushed by andre.bargull@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/ab6bffa5f865
Part 1: Update or remove ICU patches. r=platform-i18n-reviewers,gregtatum
https://hg.mozilla.org/integration/autoland/rev/fc0b9787a3db
Part 2: Update in-tree ICU to 73. r=platform-i18n-reviewers,gregtatum
https://hg.mozilla.org/integration/autoland/rev/37e4e4f46083
Part 3: Update tzdata files to 2023c. r=platform-i18n-reviewers,gregtatum
https://hg.mozilla.org/integration/autoland/rev/a7d254961504
Part 4: Update language tag mappings. r=platform-i18n-reviewers,gregtatum
https://hg.mozilla.org/integration/autoland/rev/05e8c2bcdd51
Part 5: Update numbering systems. r=platform-i18n-reviewers,gregtatum
https://hg.mozilla.org/integration/autoland/rev/dd5334f3645c
Part 6: Update currency information. r=platform-i18n-reviewers,gregtatum
https://hg.mozilla.org/integration/autoland/rev/b2c51970935e
Part 7: Remove no longer needed ICU draft API guards. r=platform-i18n-reviewers,gregtatum
https://hg.mozilla.org/integration/autoland/rev/9c7f0712f342
Part 8: Update expected test results. r=platform-i18n-reviewers,gregtatum
https://hg.mozilla.org/integration/autoland/rev/7fa850c36d96
Part 9: Bump minimum required ICU version to 73.1. r=platform-i18n-reviewers,gregtatum
https://hg.mozilla.org/integration/autoland/rev/7900405a8f15
Part 10: Updating ICU requires a clobber. r=platform-i18n-reviewers,gregtatum
https://hg.mozilla.org/integration/autoland/rev/d2cb004772ec
Part 11: Temporarily disable some test262 tests. r=spidermonkey-reviewers,sfink
https://hg.mozilla.org/integration/autoland/rev/6d91b4ed2bb8
Part 12: Update estimated memory use of ICU objects. r=spidermonkey-reviewers,sfink

Since nightly and release are affected, beta will likely be affected too.
For more information, please visit BugBot documentation.

Regressions: 1835603
Regressions: 1838173
Regressions: 1838430
Regressions: 1835362
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: