Shared user folder using not the permissions of the owner for the owner

RESOLVED DUPLICATE of bug 170597

Status

MailNews Core
Networking: IMAP
RESOLVED DUPLICATE of bug 170597
16 years ago
10 years ago

People

(Reporter: Andreas Korn, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021127
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021127

I have a subfolder of my INBOX which is Shared to other users. I have all
permissions and anyone else has "Read, Lookup, Set Read/Unread State". The
permission are set on a cyrus imap-server.
Mozilla reports (Folder Properties/Shared) to me (as owner) the permissions
"Read, Lookup, Set Read/Unread State" and to anyone else "Full Control" and
behaves accordingly. This should be reversed.
For public folders Mozilla does something similar. Anyone has "Read, Lookup, Set
Read/Unread State, Post" permissions and some users have "Full Control" from the
server side and Mozilla reports for everyone "Full Control".

On previous Mozilla versions (1.0.1, 1.1) this worked fine.

Reproducible: Always

Steps to Reproduce:
1. Setup a user folder.
2. Set the permissions for this folder to owner->all, anyone else->some
restricted permissions.
3. Check the permissions reported by Mozilla for the owner and some other user.
(Reporter)

Comment 1

16 years ago
Some Clarification:
The Problem with the shared user folders is as described, but with public
folders it is as follows:
Mozilla behaves properly regarding the permissions (when copying to the folder
or removing something from it) but reports always "Full Control" when asking. It
is possible for me (without the write or delete permissions on the folder) to
select "Move to" or "Delete Message" for a message in this folder. And then the
server says permission denied.
(Assignee)

Comment 2

16 years ago
dup, and should be fixed in today's build (20021129)

*** This bug has been marked as a duplicate of 170597 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
QA Contact: huang → gchan
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.