Closed Bug 1826591 Opened 1 year ago Closed 1 year ago

Log crashes in the ExceptionHandler if logging uncaughtExceptions cause a crash

Categories

(Fenix :: General, task, P1)

All
Android

Tracking

(firefox115 fixed)

RESOLVED FIXED
115 Branch
Tracking Status
firefox115 --- fixed

People

(Reporter: jonalmeida, Assigned: jonalmeida)

References

Details

(Whiteboard: [geckoview:m115])

Attachments

(1 file)

As an extension to bug 1826590, we should catch any exceptions thrown when the crash reporter crashes and, at the minimum, log it to the console as an error.

Something as simple as adding a catch block would suffice:

try {
    crashReporter.onCrash()
} catch (e: Exception) {
    Log.e(TAG, "Crash reporter crashed.", e)
} finally {
    terminateProcess()
}
Severity: -- → S3
Priority: -- → P1
Severity: S3 → N/A
See Also: → 1826590

I lost track of this task in 113 - fixing it now.

Status: NEW → ASSIGNED
Whiteboard: [geckoview:m113] → [geckoview:m115]
Target Milestone: --- → 115 Branch
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Flags: qe-verify+
Resolution: --- → FIXED

Hello Jonathan,

Is QA verification needed for this issue? If so, could you please provide us with some steps to reproduce (STR) or testing scenarios?

Thank you!

Clearing qe-verify since there is nothing to verify. Thanks Adina!

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: