Closed Bug 1829115 Opened 1 year ago Closed 1 year ago

New migration window is not displayed when importing data with the `-- migration` command

Categories

(Firefox :: Migration, defect, P2)

Firefox 114
Desktop
All
defect

Tracking

()

RESOLVED DUPLICATE of bug 1823537
Tracking Status
firefox-esr102 --- unaffected
firefox112 --- unaffected
firefox113 --- unaffected
firefox114 --- wontfix
firefox115 --- wontfix
firefox116 --- fixed

People

(Reporter: atrif, Unassigned)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file, 1 obsolete file)

Attached image migration_terminal.gif

Found in

  • 114.0a1 (2023-04-19)

Affected versions

  • 114.0a1 (2023-04-13)
  • 113.0b5 (default disabled)

Tested platforms

  • Affected platforms: Windows 10x64, Ubuntu 20.04, macOS 12
  • Unaffected platforms: none

Preconditions

  • browser.migrate.content-modal.enabled:true
  • have multiple browsers or multiple accounts for one browser that contains bookmarks

Steps to reproduce

  1. Open Firefox from the terminal using the -- migration command.

Expected result

  • The new migration wizard is displayed.

Actual result

  • The old migration wizard is displayed.

Regression range

  • Most likely started with the implementation of the new Import Wizard Experience.

Additional notes

  • Attached a screen recording.

I'm assigning you this one for now, Brian.

When we open the migration wizard with --migration (you can test this with ./mach run --migration), we enter here: https://searchfox.org/mozilla-central/rev/26790fecfcda622dab234b28859da721b80f3a35/browser/components/migration/MigrationUtils.sys.mjs#563

and isStartupMigration is true, meaning that we hit this else branch and open the old legacy migration wizard window:

https://searchfox.org/mozilla-central/rev/26790fecfcda622dab234b28859da721b80f3a35/browser/components/migration/MigrationUtils.sys.mjs#639-653

We did this intentionally in bug 1823536, but that was mainly for the "Firefox Reset" case where we're using the migration code to do an "almost factory reset" of a user's old Firefox profile into a new profile. We should still avoid using the new migration wizard for that case, but might be able to still use it for the --migration case.

What happens if we change that condition to be:

    let profileReset = aOptions?.isStartupMigration && aOptions?.migratorKey == "firefox";
    if (
      Services.prefs.getBoolPref(
        "browser.migrate.content-modal.enabled",
        false
      ) &&
      !profileReset
    ) {

?

Assignee: nobody → brianpt1106
Attachment #9329764 - Attachment description: WIP: Bug 1829115 - New migration window is not displayed when importing data with the command. r?mconley. → WIP: Bug 1829115 - New migration window is not displayed when importing data with the `--migration` command. r?mconley.
Attachment #9329764 - Attachment description: WIP: Bug 1829115 - New migration window is not displayed when importing data with the `--migration` command. r?mconley. → Bug 1829115 - New migration window is not displayed when importing data with the command. r?mconley.
Attachment #9329764 - Attachment description: Bug 1829115 - New migration window is not displayed when importing data with the command. r?mconley. → WIP: Bug 1829115 - New migration window is not displayed when importing data with the `--migration` command. r?mconley.
Attachment #9329764 - Attachment description: WIP: Bug 1829115 - New migration window is not displayed when importing data with the `--migration` command. r?mconley. → Bug 1829115 - New migration window is not displayed when importing data with the command. r?mconley.
Attachment #9329764 - Attachment description: Bug 1829115 - New migration window is not displayed when importing data with the command. r?mconley. → WIP: Bug 1829115 - New migration window is not displayed when importing data with the `--migration` command. r?mconley.
Priority: -- → P2

After some exploration with bpham's patch, I realize this is going to be significantly more work than can probably fit both in the 114 cycle, and to end of the CalState semester.

Brian, I'm going to try to find you something a bit smaller to round out the semester.

Assignee: brianpt1106 → nobody
Assignee: nobody → brianpt1106
Status: NEW → ASSIGNED

The following patch is waiting for review from a reviewer who resigned from the review:

ID Title Author Reviewer Status
D176194 WIP: Bug 1829115 - New migration window is not displayed when importing data with the --migration command. r?mconley. brianpt1106 mconley: Resigned from review

:brianpt1106, could you please find another reviewer?

For more information, please visit auto_nag documentation.

Flags: needinfo?(brianpt1106)

Brian, can you please mark the patch as "Abandoned" in Phabricator? That'll remove the nag.

Attachment #9329764 - Attachment description: WIP: Bug 1829115 - New migration window is not displayed when importing data with the `--migration` command. r?mconley. → WIP: Bug 1829115 - New migration window is not displayed when importing data with the `--migration` command. (Abandoned)

Sorry Brian, I should have been more clear.

At the bottom of the Phabricator page, there's a dropdown labelled "Add Actions". One of those actions is to abandon the revision. Can you choose it, and then hit Submit?

Attachment #9329764 - Attachment is obsolete: true
Assignee: brianpt1106 → nobody
Status: ASSIGNED → NEW
Status: NEW → RESOLVED
Closed: 1 year ago
Duplicate of bug: 1823537
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: