Flash 6 beta plugin stalls Mozilla, screen drawing in movies

RESOLVED WORKSFORME

Status

()

P3
critical
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: bugs, Assigned: peterl-bugs)

Tracking

({hang})

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [THIS IS A FLASH PLUG-IN ISSUE], URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021126

CPU:  AMD Athlon XP 1400 (1.2 Ghz)
Platform:  Linux (Slackware 8.1 distro, Kernel 2.4.20).
Ram:  256 MB
Browser:  Mozilla 1.2 (also happens in 1.1)
VidCard:  NVIDIA GeForce 4
Flash build number:  UNABLE TO LOCATE -- CANNOT REPORT
Previous version:  5.x
Issue with:  PLUGIN
URL:  http://www.starland.com/StoneTrek/index.html

This is best demonstrated.  Try to play any StoneTrek movie in the above URL
with Flash 6.  Any one!  Plugin v5 plays ok, but not 6 beta.



Reproducible: Always

Steps to Reproduce:




Macromedia has been emailed pointing to this bug.

Comment 1

16 years ago
wfm using build 2002120104 on Linux + Flash 6.0r61.
Flash version using either about:plugins or
http://poppy.macromedia.com/flashplayer/version/

Comment 2

16 years ago
wfm on linux with flash 6 beta and 1126 trunk. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 3

16 years ago
marking v. per last two entries
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

16 years ago
Negative.  Linux Moz build 20021126 + Flash 6.0r61 (THIS WAS A FRESH PULL!!!) 
Reopening this bug.
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 5

16 years ago
What's the kicker is when I reinstalled it, it froze Mozilla on a different
place inside one flash movie in the above URL (Episode 8, Marroned on
Tattotine), and it's also playing the video/anim part faster than the audio
(which seems to be a problem for some reason though all the plugin versions).

Comment 6

16 years ago
this is not mozilla issue this is flash 6 (linux) problem,
at least I got the same behavior using stand alone gflashplayer on
http://www.starland.com/StoneTrek/Images/MAROONED3.swf
it could be a timer problem...
ccing emillard@macromedia.com

Comment 7

16 years ago
marking as such
Priority: -- → P3
Summary: [FLASH PLUGIN] Flash 6 beta plugin stalls Mozilla, screen drawing in movies → Flash 6 beta plugin stalls Mozilla, screen drawing in movies
Whiteboard: [THIS IS A FLASH PLUG-IN ISSUE]
Target Milestone: --- → Future

Comment 8

16 years ago
There seem to be two bugs mixed together in this bug.  Is the stall still an 
issue.  I haven't reproduced it on r68 which will be released soon.  With audio 
intensive movies you need to note in the bug if you are under GNOME with esd 
running or not.  A hang bug was fixed with esd recently, it was most commonly 
seen if you did something in the browser that caused audio to not be serviced 
in a timely manner so audio backlogged. 
 
There are some known issues with video sync that probably aren't going to be 
fixed in this release because they require a redesign.  Again are you on GNOME 
with ESD.  The sync problems tend to be worse with ESD. 
(Reporter)

Comment 9

16 years ago
Let me know when r68 is out.  I am using GNOME 1.4 with ESD 0.2.27.  Also, is
there a way to have Flash use /dev/adsp0 instead of /dev/dsp (I'm using ALSA,
and have two cards in here, with /dev/dsp and /dev/adsp0 pointing to an add-in
Ensoniq 1371 baised AudioPCI card I have).

Comment 10

16 years ago
reassign
Assignee: beppe → peterl

Comment 11

16 years ago
FYI, r69 is out, I just grabbed it and installed it (my problem is the reduced
performance of version 6 vs. version 5, which I'm looking for bugs on)

Comment 12

16 years ago
I'm suffering from this bug. If I load a page which contains a flash
movie with sound, Mozilla freezes when the movie finishes playing.

I'm using gnome 1.4, esound 0.2.29, flash 6.0 r69 and Mozilla 2003020122.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 13

16 years ago
I've found that the flash plugin will stall the entire browser immediately
(Linux) upon loading a page with a flash object if ESD is installed but not
running -- it seems it will try indefinitely to connect to the server and never
time out.

My solution to this was to uninstall ESD, which I don't want anyways, but I
wonder if there's a way to force it to use OSS output instead.

Hope this is helpful to someone.

#0  0x405b2982 in __libc_connect () at __libc_connect:-1
#1  0x40208343 in connect (fd=37, addr=
      {__sockaddr__ = 0xbfff98d8, __sockaddr_at__ = 0xbfff98d8, __sockaddr_ax25_
_ = 0xbfff98d8, __sockaddr_dl__ = 0xbfff98d8, __sockaddr_eon__ = 0xbfff98d8, __s
ockaddr_in__ = 0xbfff98d8, __sockaddr_in6__ = 0xbfff98d8, __sockaddr_inarp__ = 0
xbfff98d8, __sockaddr_ipx__ = 0xbfff98d8, __sockaddr_iso__ = 0xbfff98d8, __socka
ddr_ns__ = 0xbfff98d8, __sockaddr_un__ = 0xbfff98d8, __sockaddr_x25__ = 0xbfff98
d8}, len=16) at wrapsyscall.c:193
#2  0x4214a5eb in esd_resume () from /opt/gnome/lib/libesd.so
#3  0x4214a86c in esd_open_sound () from /opt/gnome/lib/libesd.so
#4  0x411c3867 in UnixSoundESD::Open ()
   from /usr/local/mozilla/plugins/libflashplayer.so
#5  0x411c2171 in PlatformSoundMix::OpenDevice ()
   from /usr/local/mozilla/plugins/libflashplayer.so
#6  0x411c1e8d in PlatformSoundMix::PlatformConstruct ()
   from /usr/local/mozilla/plugins/libflashplayer.so
#7  0x41142135 in CoreSoundMix::Construct ()
   from /usr/local/mozilla/plugins/libflashplayer.so
#8  0x4118a3de in CoreGlobals::Init ()
   from /usr/local/mozilla/plugins/libflashplayer.so
#9  0x411617c9 in CorePlayer::CorePlayer ()
   from /usr/local/mozilla/plugins/libflashplayer.so
#10 0x411973e5 in UnixCommonPlayer::UnixCommonPlayer ()

Comment 14

15 years ago
does this still happen with Flash 6.0r81 ?
Blocks: 211213

Comment 15

15 years ago
wfm using FF 20040602 + Flash 7.0r25 on Linux.
Can anyone seeing this issue try Flash 7 and report if it works ?
Keywords: hang

Comment 16

15 years ago
No feedback, Flash 7 is available on Linux, marking WFM.
Please reopen if crashing with Mozilla 1.7rc2 or above, Flash 7.0r25 or above
and attach Talkback Incident ID.
Status: NEW → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.