Closed Bug 1831433 Opened 10 months ago Closed 9 months ago

FVWM: "Copy Download Link" from the Downloads icon doesn't work when widget.gtk.grab-pointer = 0. (It can be fixed by setting it back to its default value: 2. FVWM needs 2 which means 1.)

Categories

(Core :: Widget: Gtk, defect)

Firefox 112
Desktop
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1814291

People

(Reporter: vincent-moz, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/112.0

Steps to reproduce:

  1. Download a PDF file, e.g. https://www.cinemed.tm.fr/file-download/download/public/3664
  2. From the Downloads icon in the toolbar, right-click over the file.
  3. Select "Copy Download Link".
  4. Paste the clipboard anywhere.

Actual results:

The old clipboard contents are pasted, i.e. the clipboard has not changed. This is always reproducible.

Expected results:

The link should be copied to the clipboard.

If I do the same thing from the Downloads window (obtained with Ctrl-Shift-Y), there is no such issue: the clipboard is changed as expected.

I can see that there is no such issue with a new profile. Is there any preference that would clash with that?

The Bugbug bot thinks this bug should belong to the 'Firefox::File Handling' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → File Handling

I can reproduce the issue with Nightly 114.0a1 (2023-05-04) when I overwrite the prefs.js file with just

user_pref("widget.gtk.grab-pointer", 0);

Just in case, my window manager is FVWM. This option and the relation with some window managers was mentioned in bug 1820542.

Because this is dependent on widget.gtk.grab-pointer, I'm changing the component to Core / "Widget: Gtk".

Component: File Handling → Widget: Gtk
Product: Firefox → Core
Summary: "Copy Download Link" from the Downloads icon doesn't work → "Copy Download Link" from the Downloads icon doesn't work when widget.gtk.grab-pointer = 0
# Whether we should try to grab the pointer on popups.
#  0: Never
#  1: Always
#  2: Auto (depending on the system)
- name: widget.gtk.grab-pointer
  type: int32_t
  value: 2
  mirror: always

Thanks for the report!
FVWM needs grab-pointer, you shouldn't disable it: As of bug 1814291, widget.gtk.grab-pointer=2 means 1 instead of 0 for FVWM.
You need to set widget.gtk.grab-pointer back to its default (=2) or to 1 (both should have the same behavior).
Fix confirmed by comment 1.

Status: UNCONFIRMED → RESOLVED
Closed: 9 months ago
Duplicate of bug: 1814291
OS: Unspecified → Linux
Hardware: Unspecified → Desktop
Resolution: --- → DUPLICATE
See Also: → 1814291
Summary: "Copy Download Link" from the Downloads icon doesn't work when widget.gtk.grab-pointer = 0 → FVWM: "Copy Download Link" from the Downloads icon doesn't work when widget.gtk.grab-pointer = 0. (It can be fixed by setting it back to its default value: 2. FVWM needs 2 which means 1.)
See Also: 1814291

(In reply to Darkspirit from comment #5)

FVWM needs grab-pointer, you shouldn't disable it: As of bug 1814291, widget.gtk.grab-pointer=2 means 1 instead of 0 for FVWM.
You need to set widget.gtk.grab-pointer back to its default (=2) or to 1 (both should have the same behavior).
Fix confirmed by comment 1.

Currently this isn't really a solution as grab-pointer breaks menus even more with FVWM. See bug 1820542.

FVWM:

  • To me it sounds like this bug ("Copy download link" doesn't work) is the worse one which can be fixed by using default settings (since 110/bug 1814291).

  • bug 1820542 is not a problem as long as you click on the desired menu name you want to open (File/Edit/View/History/Bookmark/Extras/Help) instead of clicking on the wrong one and then moving your mouse to the desired one, right?

  • bug 1820542 comment 44 confirmed that bug 1820542 comment 42 fixed submenus in 114 (which becomes Stable 2023-06-06).

See Also: → 1820542

(In reply to Darkspirit from comment #7)

  • bug 1820542 is not a problem as long as you click on the desired menu name you want to open (File/Edit/View/History/Bookmark/Extras/Help) instead of clicking on the wrong one and then moving your mouse to the desired one, right?

The issue is that I don't always know which particular menu to look at. So searching for the right one is annoying.

You need to log in before you can comment on or make changes to this bug.