Closed Bug 1831920 Opened 1 year ago Closed 10 months ago

Add support for casting function types

Categories

(Core :: JavaScript: WebAssembly, task, P2)

task

Tracking

()

RESOLVED FIXED
117 Branch
Tracking Status
firefox117 --- fixed

People

(Reporter: rhunt, Assigned: bvisness)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

The casting instructions can support downcasting to a specific function type. We currently don't support this because our function object representation doesn't have the type information easily accessible.

Assignee: nobody → bvisness
Status: NEW → ASSIGNED
Attachment #9340395 - Attachment description: WIP: Bug 1831920: Implement casting for all remaining wasm types. → Bug 1831920: Implement casting for all remaining wasm types. r=rhunt

There is an r+ patch which didn't land and no activity in this bug for 2 weeks.
:bvisness, could you have a look please?
If you still have some work to do, you can add an action "Plan Changes" in Phabricator.
For more information, please visit BugBot documentation.

Flags: needinfo?(rhunt)
Flags: needinfo?(bvisness)
Pushed by bvisness@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b454d7da6a13
Implement casting for all remaining wasm types. r=rhunt,jandem

Backed out for causing jsreftest failures in eval-export-dflt-cls-anon.js

  • Backout link
  • Push with failures
  • Failure Log
  • Failure line: REFTEST TEST-UNEXPECTED-FAIL | js/src/tests/test262/language/expressions/dynamic-import/eval-export-dflt-cls-anon.js;module;async | No test results reported. (SCRIPT)
Pushed by ncsoregi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8aaf1339f918
Implement casting for all remaining wasm types. r=rhunt,jandem a=reland

Relanded this patch as it is not the cause for the permafailures mentioned in the above comment.

We apologise for the inconvenience caused!

Flags: needinfo?(rhunt)
Flags: needinfo?(bvisness)
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 117 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: