Destroys Palm Desktop User Account

VERIFIED FIXED

Status

MailNews Core Graveyard
Palm Sync
--
critical
VERIFIED FIXED
16 years ago
9 years ago

People

(Reporter: Darnell, Assigned: Sean Su)

Tracking

Other Branch
x86
Windows 2000

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

1.34 KB, patch
Sean Su
: review+
(not reading, please use seth@sspitzer.org instead)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

After installing Mozilla 1.2.1 I could no longer open my Palm Desktop software,
because my User Account had been blown away.  I mean my Palm Desktop User
account was gone.  Although the Palm Desktop files appeared to all be there the
Palm Desktop software could not find my user account. 

I had to Hotsync from my PDA to recover data, but the Windows based Palm Hotsync
application did not have my User Account and I had to perform the Hotsync as if
I were doing it for the first time as a new user.

All Palm Desktop entries made before installing Mozilla and not already in my
PDA were lost.

Reproducible: Always

Steps to Reproduce:
1. Already had Palm Desktop software installed and had been using it for some
time with my PDA (Palm Desktop & HotSync Manager 4.0.1 from Handspring).  Also
had Mozilla 1.2 installed.
2. Uninstall Mozilla 1.2
3. Install Mozilla 1.2.1
4. Attempt to open Palm Desktop software and it can not find User Account
previously used.
5. Attempt to Hotsync from PDA and receive a message about starting a new
account, although there was already an account setup before installing Mozilla
1.2.1 .

Actual Results:  
I could no longer use my Palm Desktop software till after doing a HotSync.  Any
entries not in my PDA were lost.

Expected Results:  
My Palm Desktop and Hotsync software should have opened as it used to, with all
my data using the user account already setup.  I have been using Mozilla since
before the 1.0 release and never had this problem.  I was using Palm Desktop
software the entire time too.

Comment 1

16 years ago
-> MailNews/Palm Sync
Assignee: asa → rdayal
Component: Browser-General → Palm Sync
Product: Browser → MailNews
QA Contact: asa → meehansqa
Version: Trunk → Other Branch

Comment 2

16 years ago
This also happened to me on install of Mozilla 1.2.1 with Handspring Visor
desktop software.  NOT very friendly.

Comment 3

16 years ago
worksforme ... i just upgraded from 1.2b to 1.2.1 and my palm desktop still
works just fine.  i'm using a clie, which uses palm desktop 4.1 ... i havnt
tried to use any of mozilla's palm syncing features.  windows 2000 SP2.

Comment 4

16 years ago
Same thing here... Win 2000, Palm Desktop for Sony 4.0.1.  This definitely did
not happen when I installed 1.2 last week.  I uninstalled 1.2 and installed
1.2.1 and got a message that there were no users in my database.
(Reporter)

Comment 5

16 years ago
Just wanted to add my machine has Win2K SP3 installed.

Comment 6

16 years ago
i'd like to add that i do NOT remove 1.2b from my system before upgrading, i
just had the installer write into my existing install dir.  i dont have the time
right now to try removing the dir and running the installer again today, but i
suspect that this might be where the problem lies, as that is the only surface
difference between Nick Guarracino and me.

Comment 7

16 years ago
This is weird, the Mozilla Installer doesnot really call the Palm Sync
Installer. The Palm Sync Installer is called when you click the Windows Start
Programs menu item "Mozilla/Address Book Palm Sync Install". Did you use the
Mozilla Palm Sync install feature?
(Reporter)

Comment 8

16 years ago
>Did you use the Mozilla Palm Sync install feature?

No (never ever clicked that), I have always used the Palm Desktop software to
sync my PDA data.

Comment 9

16 years ago
Sean u got any idea why this could happen?
This is true for Win2K SP3.  The problem is that the PATH registry item for the
Palm software get's changed from where you installed it (D:\Program Files\Palm
for me) to %TEMP%\ns_temp (D:\temp\ns_temp for me)  I fixed this on my system,
and got the Palm software working.  However, Mozilla then STOPPED working for
me, (this as I uninstalled 1.2.1 and reinstalled 1.2, and running quite
successfully until I fixed the Palm problem)  It had been running hanging at the
splash screen with zero disk IO, without showing as a running application under
the Task Manager, and no further disk I/O showing.  I had to kill my old profile
and recreate it to get Mozilla working again.  Why Mozilla would be changing
ANYTHING in the Palm registry is a big question for me.

Comment 11

16 years ago
It happened to me too, I also have Win2k SP3 installed. I was installing Mozilla
1.2.1 over 1.2. Bad karma in these days...

Comment 12

16 years ago
Aaahh this could be related to (infact a duplicate of) bug #182423. 

This infact is not happening because of install but because of uninstall. All
the cases here have Uninstalled Mozilla1.2 or Mozilla 1.21 which calls into Palm
Sync UnInstall. And the Palm API called during Uninstall is changing the
registry settings. So this is not really an Install issue but an Uninstall issue.
I have gone through the rigamarole, and this is an UNSTALLATION problem!

I uninstalled my Moz 1.2, and checked the registry at
HKEY_USERS\S-1-5-21-746137067-1383384898-1202660629-1000\Software\U.S.
Robotics\Pilot Desktop\Core\Path and found it set to D:\TEMP\ns_temp (my
%TEMP%\ns_temp).  I changed this value back to D:\Program Files\Palm.  Palm
Desktop works fine.  I reinstalled 1.2.1 (1.2 would work the same I'm sure) and
find that I now have both a working Palm Desktop AND a working Mozilla.  I'm not
sure why changing that registry item after installing Mozilla causes Mozilla to
stall upon starting, but it does, since I've gone through that twice now. :/

Also, it seems that the uninstall never completes, as I have to kill the
Add/Remove Programs control panel after everything has settled down (MSHTA.EXE)

Comment 14

16 years ago
My PalmDesk Top lost my user name when I uninstalled M1.2 Intrestingly I had not
even ran or installed Mozilla hotsync. To recover I unistalled and reinstalled
the Palmdesk top. If this was not a fluke, ininstalling M1.2 or M1.2.1 can be a
bit of a pain even if you do not hotsync with it.

Comment 15

16 years ago
The fix in comment #13 worked for me (I had unistalled M1.2 and installed M1.2.1
and could not start up Palm Desktop).  I'm running WinME on a laptop.
(Assignee)

Comment 16

16 years ago
Created attachment 108272 [details] [diff] [review]
quick patch

This is a quick patch that will prevent mozilla's uninstaller from calling
PalmSyncInstall.exe in it's unisntall mode.

However, if someone had called PalmSyncInstall.exe to install, they would have
to run the palmsync uninstaller manualy via the Start menu shortcut.

This will not fix systems that already ran into this bug.  This will just
prevent this bug from happening during the Mozilla uninstall process.
Comment on attachment 108272 [details] [diff] [review]
quick patch

r=dmose providing that you add a comment to the code describing why this stuff
is being commented out
Attachment #108272 - Flags: review+
(Assignee)

Comment 18

16 years ago
Created attachment 108291 [details] [diff] [review]
quick patch with comments
Attachment #108272 - Attachment is obsolete: true
(Assignee)

Comment 19

16 years ago
Comment on attachment 108291 [details] [diff] [review]
quick patch with comments

moving r=dmose to here. seeking sr= now
Attachment #108291 - Flags: superreview?(syd)
Attachment #108291 - Flags: review+

Updated

16 years ago
QA Contact: meehansqa → nbaca
(Assignee)

Updated

16 years ago
Attachment #108291 - Flags: superreview?(syd) → superreview?(sspitzer)
Comment on attachment 108291 [details] [diff] [review]
quick patch with comments

sr=sspitzer
Attachment #108291 - Flags: superreview?(sspitzer) → superreview+
(Assignee)

Updated

16 years ago
Attachment #108291 - Flags: approval1.3a?

Comment 21

16 years ago
Comment on attachment 108291 [details] [diff] [review]
quick patch with comments

a=asa for checkin to 1.3a
Attachment #108291 - Flags: approval1.3a? → approval1.3a+
(Assignee)

Comment 22

16 years ago
taking
Assignee: rdayal → ssu
(Assignee)

Comment 23

16 years ago
patch checked in to both mozilla and ns trees.  This does not solve the problem
with the mozilla palm sync installer.  it just prevents it for those who have
not ran the mozilla palm sync installer.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 24

16 years ago
Trunk build 2003-02-12: WinXP
Verified Fixed. 

- After installing today's build and installing the Mozilla Address Book
conduit, I was able to open the Palm Desktop software and see accounts,
categories and records.
- Then after uninstalling the Mozilla Address Book Conduit, I was still able to
open the Palm Desktop software and see accounts, categories and records.
Status: RESOLVED → VERIFIED

Comment 25

16 years ago
I too experienced the problems described here, but have so far been unable to
get my Palm to sync with the Palm desktop sw again. I have checked the registry
as described, but all appears fine. Here're some more details.

After installing Mozilla 1.2.1, and installing the sync conduit via the start
menu, I successfully synced my PDA with the Mozilla AB. I then uninstalled using
the start menu, and could no longer sync with the desktop.

I suspected some registry problem but, not knowing much about the Windows
platform, didn't know how to start chasing this. So this is what I did:

1. Backed up all the Palm desktop data
1. Uninstall Palm desktop (v3.1)
2. Uninstall Mozilla
3. Reinstall Palm desktop
4. Create a new user account in the Palm sw

Then I tried a sync with my Palm. I configured a custom sync so that the only
operation was to sync the datebook, with the handheld overwriting the desktop.
The sync operation hung, and I had to reset the PDA and kill the desktop sw. I
then tried a similar thing, but specified that the datebook should synchronise
with the desktop. Same result.

Curiously, I can successfully sync expense reports. The hotsync log in C:\Palm
contains appropriate details.

So I had a browse through these bugs, and checked the registry keys:

HKEY_CURRENT_USER\Software\U.S. Robotics\Pilot Desktop\Core\Path is C:\Palm
HKEY_CURRENT_USER\Software\U.S. Robotics\Pilot Desktop\Core\HotSyncPath is
C:\Palm\Hotsync.exe.

HKEY_USERS\S-1-5-21-318508274-1301046853-445584762-1000\Software\U.S.
Robotics\Pilot Desktop\Core and <>\HotSyncPath are as above.

So, those two keys look ok. I left the above sync ops running for ~10mins, which
should be ample time. No io seemed to occur. The file datebook.dat was touched
(new timestamp) but no data was added. I've also tried a complete reinstall of
the desktop sw in a new windows account, but the same situation occurs.

Any suggestions about how I can proceed here? Thanks.

Comment 26

16 years ago
Some more info on this: it's just the datebook that can't be synced. If this
application sync is turned off, everything else works fine.
Product: MailNews → Core
Product: Core → MailNews Core

Updated

9 years ago
Component: Palm Sync → Palm Sync
Product: MailNews Core → MailNews Core Graveyard
You need to log in before you can comment on or make changes to this bug.