infinite loop when attempting to read XUL.mfasl

VERIFIED DUPLICATE of bug 169777

Status

--
critical
VERIFIED DUPLICATE of bug 169777
16 years ago
14 years ago

People

(Reporter: Leknor, Assigned: asa)

Tracking

({hang})

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Mozilla is up and running and I try to open Mozilla Mail and Mozilla hands. By
using strace on linux I can see that Mozilla is in an infinate loop and strace
outputs:

read(10, "", 8192)                      = 0

searching though the strace output I found out while file that is:

open("/home/sandymac/.mozilla/default/tphrpkhk.slt/XUL.mfasl",
O_RDONLY|O_LARGEFILE) = 10

By simply moving the file out of the way mozilla started working again.

It appears there is a read loop somewhere that does not gracefully handle how
ever this file is corrupted. I will add the strace output and the problem file
XUL.mfasl to this bug report.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

16 years ago
The problem files are about 600K compressed and bugzilla only allows up to 300K
attachments so I've made the files available at:
http://flick.nerdc.ufl.edu/moz-lockup/
The zip file contains the other two files.

Also, I can recreate the problem at will so if you want any other form of
debugging output just ask and I'll see what I can do.
Summary: infinate loop when attempting to read XUL.mfasl → infinate loop when attempting to read XUL.mfasl

Updated

16 years ago
Keywords: hang

Comment 3

16 years ago
Dupe.

If anyone can reproduce this problem with a current nightly trunk build, please
report that to bug 169777.

*** This bug has been marked as a duplicate of 169777 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Summary: infinate loop when attempting to read XUL.mfasl → infinite loop when attempting to read XUL.mfasl

Comment 4

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.