Closed Bug 1833979 Opened 9 months ago Closed 9 months ago

Fetch in web worker not shown in network monitor

Categories

(Core :: Networking, defect)

Firefox 112
defect

Tracking

()

RESOLVED DUPLICATE of bug 1819570

People

(Reporter: liumeo, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/113.0

Steps to reproduce:

index.html:
<!DOCTYPE html>
<html>
<head>
<title>Worker fetch</title>
</head>
<body>
<script>
new Worker('./worker.js')
</script>
</body>
</html>

worker.js:
fetch('./worker.js').then(console.log)

Actual results:

In Firefox 112 and later, only one request is shown in network monitor.

Expected results:

In Firefox 111, there are 2 requests for worker.js, and the second one is the fetch.
Note: this bug has nothing to do with the fact that worker.js is cached. Changing the fetch in worker.js to another file in the same directory can still reproduce the bug.

The Bugbug bot thinks this bug should belong to the 'Core::Networking' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Networking
Product: Firefox → Core

Thank you for filing this bug report.
Can you provide http logs for the fetch case in 112?
You can send to email necko@mozilla.com if you are concerned about sensitive personal information.

Flags: needinfo?(liumeo)
Flags: needinfo?(liumeo)
Status: UNCONFIRMED → RESOLVED
Closed: 9 months ago
Duplicate of bug: 1819570
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.