Closed Bug 18341 Opened 20 years ago Closed 17 years ago

Integrated Two Panel Bookmark/History Editor

Categories

(SeaMonkey :: UI Design, enhancement, P3)

enhancement

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 112531
Future

People

(Reporter: jonx.williams, Unassigned)

References

()

Details

I had an idea about a browser enhancement that I may try to implement as a Java
based plugin if possible.

Create a window that has two panels.  One panel lists all the bookmarks for the
user.  One panel lists the browser history in a fashion similiar to IE4.0
(grouped by date).

Both sets of information have COMMON information such as date.  The window
provides edit capabilities for all bookmarks and history items.  The browser
controls history expiration.

MAJOR FUNCTION:  A person does not need to bookmark items as he browses the
internet.  He can open the bookmark/history editor and browse through the
history and drag history items into the bookmark section in the other panel.
he can also put bookmarks back into the history list.

MAJOR FUNCTION:  Provide capability to do a text based search that will CRAWL
through the history list and find key words.  I have already demonstrated such
functionality.
Assignee: leger → don
Component: Browser-General → XPApps
QA Contact: leger → don
Summary: Integrated Two Panel Bookmark/History Editor → RFE:Integrated Two Panel Bookmark/History Editor
Target Milestone: M20
Setting RFE milestone.
Move to "Future" milestone.
Target Milestone: M20 → Future
Since Don has left, Vishy is taking his bugs in bulk, pending reassignment.
thanks,
	Vishy
Assignee: don → vishy
nav triage team:

We're trying to make history better, but not sure will implement this. Marking 
nsbeta1-
Keywords: nsbeta1-
QA Contact: don → sairuh
QA Contact: sairuh → claudius
Cc mpt.

I don't think this rfe would be very useful, since people tend to visit many 
more urls than they will want to visit later.  Having the ability to bookmark 
an item directly from history (bug 61178) might be useful, though.
i don't think this is worth it.  Having bookmarks and history open side by side 
gives as much functionality as can be gleaned from an integrated view.
--> Ben
Assignee: vishy → ben
Component: XP Apps → XP Apps: GUI Features
Interesting idea, but make it an add-on. I don't see this as being an integral 
part of our default implementation. -> nobody, helpwanted
Assignee: ben → nobody
Keywords: helpwanted
I'm working with similar ideas at mozhoo.mozdev.org. Contributors welcome.

*** This bug has been marked as a duplicate of 112531 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Keywords: helpwanted
Resolution: --- → DUPLICATE
Summary: RFE:Integrated Two Panel Bookmark/History Editor → Integrated Two Panel Bookmark/History Editor
verified duplicate
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.