Menu bar non-functional when download status window displayed

RESOLVED DUPLICATE of bug 100179

Status

()

RESOLVED DUPLICATE of bug 100179
16 years ago
10 years ago

People

(Reporter: cmason, Assigned: bugzilla)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3a) Gecko/20021202
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3a) Gecko/20021202

Menu bar doesn't function (either menu's title is highlighted and it doesn't
drop down, or menu appears but does not fire events) when download status window
is focused.  This may be related to Bug 132027 (which concerns the download
manager).

Reproducible: Always

Steps to Reproduce:
1. start downloading something.  status window appears.
2. while status window is focused, choose a menu item (such as
File->New->Navigator Window)
3. nothing happens, menu title remains highlighted

Also, try:

1. Start downloading something.
2. Close all other windows.
3. Menu bar doesn't work: title is highlighted but menu doesn't drop down.
Actual Results:  
Menubar menus either don't appear or doesn't fire events.

Expected Results:  
Menu should appear and perform expected action (in the example: new navigator
window should appear).

Only tried this on MachO build.  Minimizing or unfocusing the download status
window produces expected results.

Comment 1

16 years ago
Confirmed using FizzillaMach/2002112607.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
-> pinkerton. I think this is a known problem (?).
Assignee: hyatt → pinkerton
not my problem. it's an app's problem.
Assignee: pinkerton → blaker
since there hasn't been activity on this bug in a couple weeks, confirming this
is still present in OS X CFM 2002121908

Did find a workaround, if you minimize the download status window (so there are
no windows visible outside of the dock), the menu bar works again.

It's quite disconcerting if I closed my last browser window and left something
downloading, and I can't get a new browser window again.

Comment 5

16 years ago
Dup.

*** This bug has been marked as a duplicate of 155426 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 6

16 years ago
Wrong dup. Reopening.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 7

16 years ago

*** This bug has been marked as a duplicate of 100179 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.