All users were logged out of Bugzilla on October 13th, 2018

[Email-In] bugzilla_email_append.pl doesn't set bugs.delta_ts

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
16 years ago
11 years ago

People

(Reporter: andemar, Assigned: nobody)

Tracking

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010923
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010923

When using the email interface of Bugzilla the timestamp of a bug indicating the
last change is not updated.
Technically speaking:
bugzilla_email_append.pl doesn't set bugs.delta_ts


Reproducible: Always

Steps to Reproduce:
1. Create a bug
2. Reply to the mail from the bugzilla-daemon
3. Look at the change date of the bug in a bug list

Actual Results:  
The date stayed the same.

Expected Results:  
New date.

Comment 1

15 years ago
This probably never got looked at because the owner of that script doesn't even
have a bugzilla account. I would suggest you email him directly for updates.

By the way, that script looks so old that I think it should probably be removed
until further notice.

-M
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Component: Creating/Changing Bugs → Bugzilla-General
Resolution: --- → INVALID
Version: unspecified → 2.17.6
We plan to make this a part of the main code soon. (or at least something
similar to it).  On the off chance we actually use this as the base for it, this
bug needs to stay open.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
confirmed.  The code to update the timestamp is not present.
Assignee: myk → nobody
Blocks: 94850
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Target Milestone: --- → Bugzilla 2.20

Comment 4

15 years ago
Created attachment 139756 [details] [diff] [review]
delta_ts patch

This patch was applied to the 2.17.6 release.  It does more than fix the
delta_ts problem.  

- handles delta_ts
- works for 2.17.6 (drops processmail and uses BugMail::Send)
- does not add Subject text if it's already a repeat of the summary header
- allows for white spaces when processing the "[Bug #]" text
- includes fixes from bug #162335
  - emails back if the bug id does not exist and exits cleanly
- it doesn't handle attachments or multi-part data (I don't think that
  ever worked in the first place)

BTW, the way things gets included was a bit confusing.	I ended up
removing the chdir/push lines but have left it in for this patch.

Comment 5

14 years ago
Created attachment 160802 [details] [diff] [review]
unidiff version of delta_ts patch

I needed albert ting's patch (attachment (id=139756)), but his is an icky unix
patch. I converted it into a unidiff patch, which should greatly help anyone
who (like me) has other patches to bugzilla_email_append.pl and is trying to
get some of the bugfixes out, but not others (or whatever).

Contextless patches suck! diff -u is your friend.

Comment 6

14 years ago
Thanks Tyler! I've already been converted to "diff -u", but didn't realize this
was still around.

Comment 7

14 years ago
Comment on attachment 160802 [details] [diff] [review]
unidiff version of delta_ts patch

Whoops. Wrong set of diffs. Obsoleting.
Attachment #160802 - Attachment is obsolete: true

Comment 8

14 years ago
Created attachment 160803 [details] [diff] [review]
delta ts patch unidiff fix

Ok, this is (hopefully!) the right one.

I also fixed a misplacement of a use line and changed a chop to chomp (i'm
pretty sure that's what was meant).

Comment 9

14 years ago
For futere expansion/localization should there be a template for the error
e-mail in the DealWithError?

Comment 10

14 years ago
Idea is to use something like Param('whinemail') used in whineatnews.pl or 
Param("voteremovedmail") inside RemoveVotes subroutine in globals.pl.

The PerformSubsts should definitely be used for composition.

Comment 11

14 years ago
Comment on attachment 160803 [details] [diff] [review]
delta ts patch unidiff fix

Looks like nobody ever asked for review on this patch.
Attachment #160803 - Flags: review?(justdave)

Comment 12

14 years ago
Comment on attachment 160803 [details] [diff] [review]
delta ts patch unidiff fix

Please break this patch down to something that handles only the summary of this
bug, and file other bugs for the other problems.
Attachment #160803 - Flags: review?(justdave) → review-

Comment 13

14 years ago
OK, nobody's working on this, unless we suddenly start getting some response
from the person who posted the patch originally. So we're just going to untarget
it entirely.
Summary: bugzilla_email_append.pl doesn't set bugs.delta_ts → [Email-In] bugzilla_email_append.pl doesn't set bugs.delta_ts
Target Milestone: Bugzilla 2.20 → ---

Updated

13 years ago
No longer blocks: 94850

Updated

13 years ago
QA Contact: mattyt-bugzilla → default-qa

Comment 14

11 years ago
email_in.pl does this. WFM
Status: NEW → RESOLVED
Last Resolved: 15 years ago11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.