Closed Bug 1835695 Opened 1 year ago Closed 1 year ago

"Search with Google" is hidden for Rich Entities entries when accessed by keyboard

Categories

(Firefox :: Address Bar, defect)

Firefox 115
defect

Tracking

()

VERIFIED FIXED
116 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox113 --- unaffected
firefox114 --- unaffected
firefox115 --- disabled
firefox116 --- verified

People

(Reporter: phorea, Assigned: daleharvey)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Note
*

Found in

  • 115.0a1 2023-05-29

Affected versions

  • Nightly 115.0a1 2023-05-29

Tested platforms

  • Affected platforms: Win 10 64-bit, OSX 10.14
  • Unaffected platforms: -

Preconditions

  • browser.urlbar.richSuggestions.featureGate set to true.
  • Connect to stage-preview using RS devtools addon.
    Run the following snippet in the Browser Console: Services.prefs.getDefaultBranch("").setCharPref("browser.search.param.search_rich_suggestions", "fen")

Steps to reproduce

  1. Type a popular keyword inside the Address Bar - Search suggestions are shown alongside Rich entities.
  2. Navigate through the Rich suggestions list using TAB and Up/Down arrow keys.

Expected result
Rich entities are autofilled in the address bar, Search with Google is visible for each selection.

Actual result
Search with Google label is missing on keyboard selection, it is only visible on mouse hover.

Regression range

:daleharvey, since you are the author of the regressor, bug 1832518, could you take a look?

For more information, please visit BugBot documentation.

Flags: needinfo?(dharvey)

Set release status flags based on info from the regressing bug 1832518

Assignee: nobody → dharvey
Flags: needinfo?(dharvey)
Pushed by dharvey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1cb6793a3494
Ensure urlbar result action is shown on keyboard navigation. r=dao
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 116 Branch

Verified as fixed in Firefox 116 beta 2, across OSes, while connected to stage and enrolled in a Rich Entities experiment. "Search with Google" is now visible on keyboard navigation.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: