If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

View page source of view page source

RESOLVED DUPLICATE of bug 159337

Status

Camino Graveyard
General
RESOLVED DUPLICATE of bug 159337
15 years ago
15 years ago

People

(Reporter: Mark Mentovai, Assigned: saari (gone))

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021202 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021202 Chimera/0.6+

When executing a "view page source" command while already in a "view page
source" tab, Chimera opens up a new tab which perpetually displays "Loading..."
and a download is initiated.

The new tab serves no purpose.  The download stores the original file to disk,
with what appears to be a hash of some sort (cache entry hash?) as its filename.

"View source" of "view source" is undefined...

Mark

Reproducible: Always

Steps to Reproduce:
Visit some page.
Press Command-E (View Page Source).
Press Command-E again.
Actual Results:  
Chimera opened up a new tab that perpetually displayed "Loading..." and began a
download of the page source.

Expected Results:  
It should have done something else.  Beeping and preventing the user from
viewing the source of source should be appropriate.

0.6.0+-2002120204/10.2.2

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 159337 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.