Inconsistent behaviour for different Japanese locale names

VERIFIED DUPLICATE of bug 18338

Status

defect
P3
normal
VERIFIED DUPLICATE of bug 18338
20 years ago
11 years ago

People

(Reporter: ji, Assigned: tao)

Tracking

Trunk
Other
Linux

Firefox Tracking Flags

(Not tracked)

Details

()

Build: 1999110911
OS: RH6.0

On Linux, there are multiple Japanese locale names
pointing to the same euc locale: ja, ja_JP.EUC and ja_JP.ujis.
And it looks like the behaviour is inconsistent between those Ja
locale names. This is observed when I tested sorting order for Japanese
mails. If there are links from ja_JP.EUC to ja or ja_JP.ujis to ja.
The links might be broken for the charset mapping table and some other
locale libraries.

Steps of reproduce:

Unzip the file shown in the URL aboce, you'll get sortjpn mail folder.
Put the mail folder under the pop mail directory.
1. Start mozilla in ja locale, go to sortjpn mail folder
   click on Subject title bar, you'll see the sorting order
   is totally messed up.
2. Start mozilla in ja_JP.EUC or ja_JP.ujis locale, do the same operation as 1.
   you'll see the sorting order is different with the order observed in step1.
   The sorting order is not completely expected, but it's much better than
   the order we got in step 1.
Status: NEW → ASSIGNED
This is a same kind of problem as 18338. We need to check if this is a locale
support issue of Linux. So trying other unix platform will help to isolate the
problem.
Currently all IQA machines are with: locale-ja-2.1.1.1-2.noarch.rpm
as the reference Japanese locale. Since there is no "standard" Japanese
locale established for Linux, this is sort of a makeshift locale
package. As explained in the distribution note, the intent of
the packager is to use "ja" as the normal name and all other
locale aliases are symbolically linked to this locale directory.

See the directory /usr/share/locale for symlinks for other locales.
At least for the users of this "ja" package, the expectation is
that "ja" should work as other aliases.
I meant other unix platforms as whatever supported in 4.x (e.g. Sun) since we do
basically the same thing for the collation key generation. Trying those systmes
helps isolating the problem.
Here is my finding with 4.7RTM US_EXPORT version on Solaris 2.6:
On Solaris 2.6, ja is the euc locale name, and japanese is an alias of ja locale.
Both in ja and japanese locale, the sorting order of test folder sortjpn's subject field is
same as the sorting order I got with ja_JP.EUC locale on linux 5.0, which is very close
to the expected result.

There might be some other broken links for these two locales. So the problem described here is not totally
same as the one described in 18338.
Browser    OS           locale      sorting
5.0       Linux         ja_JP.EUC    OK
5.0       Linux         ja           Wrong
5.0       Linux         fr           Wrong
5.0       Linux         fr_FR        Wrong
4.7       Solaris 2.6   ja           OK
4.7       Solaris 2.6   japanese     OK
Assignee: nhotta → tao
Status: ASSIGNED → NEW
Take it over from Naoki.
Target Milestone: M13
Mark it M13 for now unless there is an objection.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Per Naoki's comment, mark it as a dup.

*** This bug has been marked as a duplicate of 18338 ***
QA Contact: momoi → ji
Over to ji for verification.
Status: RESOLVED → VERIFIED
The sorting order under ja and ja_JP.EUC is same now. Either of them is
correct though.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.