Closed Bug 18366 Opened 20 years ago Closed 20 years ago

[BLOCK] ContentAppend causes the select frame to be deleted and recreate (WipeContainingBlock problem)

Categories

(Core :: Layout, defect, P3, major)

All
Windows NT
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: rods, Assigned: waterson)

References

Details

ContentAppend calls WipeContainingBlock which caues the nsListControlFrame to be
deleted and recreated which is wrong. Currently, as a work-around we check to
see if it is a select frame and then we don't call it.
Assignee: troy → kipp
Updating to default Layout Assignee...kipp no longer with us :-(
Why are you re-reassing layout bugs? Do NOT touch layout bugs.

The bugs are assigned to Kipp so they can stay neatly organized until we have a
new owner for the block/inline code.
rod:  with your workaround in place, how severe a problem is this?  I'm trying
to find a milestone for it, and I'm inclined to move it out past beta if you
have a successful workaround.
mass moving all Kipp's pre-beta bugs to M15.  Nisheeth and I will
prioritize these and selectively move high-priority bugs into M13 and M14.
Target Milestone: M15 → M14
Summary: ContentAppend causes the select frame to be deleted and recreate → [BLOCK] ContentAppend causes the select frame to be deleted and recreate
Troy:  Rod said you had some insight into the problems caused by 
WipeContainingBlock.  How about a quick summary?
Summary: [BLOCK] ContentAppend causes the select frame to be deleted and recreate → [BLOCK] ContentAppend causes the select frame to be deleted and recreate (WipeContainingBlock problem)
troy:  also, how about a comment about whether this is a beta blocker, or 
whether it can be fixed post-beta (if you have an opinion on the matter.)
I think the wipe containing block nonsense needs to be fixed before we go 
to beta.

We don't have to improve all of the cases, just the case of appeneded content
Blocks: 22810
moved to M15
Target Milestone: M14 → M15
mine! mine mine mine!  all mine!  whoo-hoo!
Assignee: kipp → buster
moving all buster m15 bugs to m16.
Target Milestone: M15 → M16
nisheeth is working on WCB issues.
Assignee: buster → nisheeth
Accepting bug...
Status: NEW → ASSIGNED
Blocks: 40246
taking
Assignee: nisheeth → waterson
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
Target Milestone: M16 → M17
We'll keep the hack for now. At some point, if we decide to re-write 
WipeContainingBlock to be smarter, we'll deal with this then.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.