Closed Bug 18369 Opened 20 years ago Closed 20 years ago

CRASH: Resized window to get scrollbar in sidebar

Categories

(Core :: Layout: Tables, defect, P3, critical)

x86
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 16929

People

(Reporter: selmer, Assigned: alecf)

Details

Needed a scrollbar in the sidebar to reproduce bug #17146.  Initially was OK,
but when I shrunk the window a second time, I crashed with this stack trace:

FixedTableLayoutStrategy::AssignPreliminaryColumnWidths(int 6000) line 122 + 15
bytes
BasicTableLayoutStrategy::Initialize(nsSize * 0x00000000, int 1, int 6000) line
112
nsTableFrame::BalanceColumnWidths(nsIPresContext & {...}, const
nsHTMLReflowState & {...}, const nsSize & {...}, nsSize * 0x00000000) line 2890
nsTableFrame::Reflow(nsTableFrame * const 0x02a0e1e0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 1291
nsTreeFrame::Reflow(nsTreeFrame * const 0x02a0e1e0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 330 + 25 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x02a0e1e0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 405 + 31 bytes
nsTableOuterFrame::Reflow(nsTableOuterFrame * const 0x02a0e9c0, nsIPresContext &
{...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned
int & 0) line 900 + 34 bytes
nsBlockReflowContext::ReflowBlock(nsIFrame * 0x02a0e9c0, const nsRect & {...},
int 0, int 0, int 1, nsMargin & {...}, unsigned int & 0) line 251 + 45 bytes
nsBlockFrame::ReflowBlockFrame(nsBlockReflowState & {...}, nsLineBox *
0x02a27680, int * 0x0012c82c) line 3226 + 59 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineBox * 0x02a27680, int
* 0x0012c82c, int 0) line 2614 + 20 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 2425 + 27 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x02a0d420, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 1489 + 15 bytes
nsBoxFrame::FlowChildAt(nsIFrame * 0x02a0d420, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0,
nsCalculatedBoxInfo & {...}, int & 0, nsString & {...}) line 1072
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0, nsRect & {...}) line 646
nsBoxFrame::Reflow(nsBoxFrame * const 0x00e18d88, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 508
nsContainerFrame::ReflowChild(nsIFrame * 0x00e18d88, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 405 + 31 bytes
RootFrame::Reflow(RootFrame * const 0x02a0cd70, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 332
nsContainerFrame::ReflowChild(nsIFrame * 0x02a0cd70, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 405 + 31 bytes
ViewportFrame::Reflow(ViewportFrame * const 0x02a0b110, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 514
PresShell::ResizeReflow(PresShell * const 0x029d9f10, int 6000, int 660) line
1082
PresShell::ResizeReflow(PresShell * const 0x029d9f14, nsIView * 0x029da310, int
6000, int 660) line 2466
nsViewManager::SetWindowDimensions(nsViewManager * const 0x029d8160, int 6000,
int 660) line 378
nsViewManager::DispatchEvent(nsViewManager * const 0x029d8160, nsGUIEvent *
0x0012d6d0, nsEventStatus & nsEventStatus_eIgnore) line 1603
HandleEvent(nsGUIEvent * 0x0012d6d0) line 67
nsWindow::DispatchEvent(nsWindow * const 0x029da1d4, nsGUIEvent * 0x0012d6d0,
nsEventStatus & nsEventStatus_eIgnore) line 407 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012d6d0) line 428
nsWindow::OnResize(nsRect & {...}) line 3333 + 15 bytes
nsWindow::ProcessMessage(unsigned int 71, unsigned int 0, long 1235244, long *
0x0012d8bc) line 2762 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x0008024a, unsigned int 71, unsigned int 0, long
1235244) line 585 + 27 bytes
USER32! 77e719d0()
USER32! 77e730a3()
NTDLL! 77f763a3()
DocumentViewerImpl::SetBounds(DocumentViewerImpl * const 0x029914d0, const
nsRect & {...}) line 479
nsWebShell::SetBounds(nsWebShell * const 0x02996e30, int 0, int 0, int 400, int
44) line 1230
nsHTMLFrameInnerFrame::Reflow(nsHTMLFrameInnerFrame * const 0x02991170,
nsIPresContext & {...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState &
{...}, unsigned int & 0) line 911
nsContainerFrame::ReflowChild(nsIFrame * 0x02991170, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 405 + 31 bytes
nsHTMLFrameOuterFrame::Reflow(nsHTMLFrameOuterFrame * const 0x02991550,
nsIPresContext & {...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState &
{...}, unsigned int & 0) line 362
nsBoxFrame::FlowChildAt(nsIFrame * 0x02991550, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0,
nsCalculatedBoxInfo & {...}, int & 0, nsString & {...}) line 1072
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0, nsRect & {...}) line 646
nsBoxFrame::Reflow(nsBoxFrame * const 0x0253b710, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 508
nsBoxFrame::FlowChildAt(nsIFrame * 0x0253b710, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0,
nsCalculatedBoxInfo & {...}, int & 0, nsString & {...}) line 1072
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0, nsRect & {...}) line 646
nsBoxFrame::Reflow(nsBoxFrame * const 0x025380f0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 508
nsBoxFrame::FlowChildAt(nsIFrame * 0x025380f0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0,
nsCalculatedBoxInfo & {...}, int & 0, nsString & {...}) line 1072
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0, nsRect & {...}) line 646
nsBoxFrame::Reflow(nsBoxFrame * const 0x025365e8, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 508
nsBoxFrame::FlowChildAt(nsIFrame * 0x025365e8, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0,
nsCalculatedBoxInfo & {...}, int & 1, nsString & {...}) line 1072
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0, nsRect & {...}) line 646
nsBoxFrame::Reflow(nsBoxFrame * const 0x00ebfdf0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 508
nsContainerFrame::ReflowChild(nsIFrame * 0x00ebfdf0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 405 + 31 bytes
RootFrame::Reflow(RootFrame * const 0x028ac3d0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 332
nsContainerFrame::ReflowChild(nsIFrame * 0x028ac3d0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 405 + 31 bytes
ViewportFrame::Reflow(ViewportFrame * const 0x028ac6c0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 514
PresShell::ResizeReflow(PresShell * const 0x0233b160, int 6540, int 3075) line
1082
PresShell::ResizeReflow(PresShell * const 0x0233b164, nsIView * 0x0233b540, int
6540, int 3075) line 2466
nsViewManager::SetWindowDimensions(nsViewManager * const 0x0233ba40, int 6540,
int 3075) line 378
nsViewManager::DispatchEvent(nsViewManager * const 0x0233ba40, nsGUIEvent *
0x0012f560, nsEventStatus & nsEventStatus_eIgnore) line 1603
HandleEvent(nsGUIEvent * 0x0012f560) line 67
nsWindow::DispatchEvent(nsWindow * const 0x0233b404, nsGUIEvent * 0x0012f560,
nsEventStatus & nsEventStatus_eIgnore) line 407 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012f560) line 428
nsWindow::OnResize(nsRect & {...}) line 3333 + 15 bytes
nsWindow::ProcessMessage(unsigned int 71, unsigned int 0, long 1243068, long *
0x0012f74c) line 2762 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x0002017a, unsigned int 71, unsigned int 0, long
1243068) line 585 + 27 bytes
USER32! 77e719d0()
USER32! 77e730a3()
NTDLL! 77f763a3()
DocumentViewerImpl::SetBounds(DocumentViewerImpl * const 0x02283170, const
nsRect & {...}) line 479
nsWebShell::SetBounds(nsWebShell * const 0x022c2450, int 0, int 0, int 436, int
205) line 1230
nsWebShellWindow::HandleEvent(nsGUIEvent * 0x0012f94c) line 532
nsWindow::DispatchEvent(nsWindow * const 0x022b6444, nsGUIEvent * 0x0012f94c,
nsEventStatus & nsEventStatus_eIgnore) line 407 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012f94c) line 428
nsWindow::OnResize(nsRect & {...}) line 3333 + 15 bytes
nsWindow::ProcessMessage(unsigned int 71, unsigned int 0, long 1244072, long *
0x0012fb38) line 2762 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x00070146, unsigned int 71, unsigned int 0, long
1244072) line 585 + 27 bytes
USER32! 77e719d0()
USER32! 77e730a3()
NTDLL! 77f763a3()
USER32! 77e718d2()
USER32! 77e727fe()
USER32! 77e72889()
nsWindow::WindowProc(HWND__ * 0x00070146, unsigned int 274, unsigned int 61448,
long 22282674) line 592 + 31 bytes
USER32! 77e719d0()
USER32! 77e71982()
NTDLL! 77f763a3()
USER32! 77e718d2()
USER32! 77e727fe()
USER32! 77e72889()
nsWindow::WindowProc(HWND__ * 0x00070146, unsigned int 161, unsigned int 17,
long 22282674) line 592 + 31 bytes
USER32! 77e71820()
MIME! 015401b2()
Assignee: troy → karnaze
Component: Layout → HTMLTables
Summary: CRASH: Resized window to get scrollbar in sidebar → CRASH: Resized window to get scrollbar in sidebar
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
I can't reproduce this on a 11/9 debug NT build. I don't think the sidebar
supports horizontal scroll bars, since shrinking it didn't produce one. I
resized the app to get a horizontal scroll bar on the document but had no crash.
Status: RESOLVED → REOPENED
Download the 1999-11-09-11 build from sweetlou and install via seamonkey32e.exe.
run it
use sidebar customize to remove what's related panel
open bookmarks panel
use VERTICAL resize to shrink the window until bookmarks has a VERTICAL
scrollbar
scroll the knob into the middle of the range
vertically resize the window back to its original size
move the scrollbar knob (that shouldn't be there)
CRASH.

N.B.  I am not shrinking the sidebar using the grippy, I am shrinking the entire
browser window by moving the bottom toward the top.
I've sent in a talkback report, but the talkback interface went away before I
could see if it gave me an ID.  Anyway, it was filed today.

This is 100% reproducible following the steps just outlined.
Resolution: WORKSFORME → ---
Clearing WORKSFORME Resolution due to reopen of this bug.
Assignee: karnaze → trudelle
Status: REOPENED → NEW
Using an 11/10 debug WinNT build I'm seeing a different stack. Peter, even if I
had seen the original stack, I think it involves trees.

nsXULDocument::AttributeChanged(nsXULDocument * const 0x02691cb0, nsIContent *
0x0264fef0, int 0, nsIAtom * 0x011b2d10 {"curpos"}, int -1) line 1194 + 25 bytes
nsXULElement::SetAttribute(nsXULElement * const 0x0264fef0, int 0, nsIAtom *
0x011b2d10 {"curpos"}, const nsString & {"0"}, int 1) line 2147
nsSliderFrame::SetCurrentPosition(nsIContent * 0x0264fef0, nsIFrame *
0x0264ded0, int 0) line 681 + 36 bytes
nsSliderFrame::HandleEvent(nsSliderFrame * const 0x0264cee0, nsIPresContext &
{...}, nsGUIEvent * 0x0012fbe0, nsEventStatus & nsEventStatus_eIgnore) line 536
PresShell::HandleEvent(PresShell * const 0x026c3e74, nsIView * 0x0264ce50,
nsGUIEvent * 0x0012fbe0, nsEventStatus & nsEventStatus_eIgnore) line 2417 + 38
bytes
nsView::HandleEvent(nsView * const 0x0264ce50, nsGUIEvent * 0x0012fbe0, unsigned
int 28, nsEventStatus & nsEventStatus_eIgnore, int & 0) line 838
nsViewManager::DispatchEvent(nsViewManager * const 0x026c04b0, nsGUIEvent *
0x0012fbe0, nsEventStatus & nsEventStatus_eIgnore) line 1743
HandleEvent(nsGUIEvent * 0x0012fbe0) line 67
nsWindow::DispatchEvent(nsWindow * const 0x026c01a4, nsGUIEvent * 0x0012fbe0,
nsEventStatus & nsEventStatus_eIgnore) line 407 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012fbe0) line 428
nsWindow::DispatchMouseEvent(unsigned int 300, nsPoint * 0x00000000) line 3424 +
21 bytes
ChildWindow::DispatchMouseEvent(unsigned int 300, nsPoint * 0x00000000) line
3642
nsWindow::ProcessMessage(unsigned int 512, unsigned int 1, long 13107356, long *
0x0012fdf0) line 2623 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x002a0800, unsigned int 512, unsigned int 1, long
13107356) line 585 + 27 bytes
USER32! DispatchMessageWorker@8 + 135 bytes
Assignee: trudelle → alecf
reassigning to alecf, who is the current point man for tree bugs.
Severity: normal → critical
what window did you first see this in?
Just opened the browser to the default location.  I did nothing special,
although I may have had my home page set to NONE at the time.
Status: NEW → ASSIGNED
ok, I think #18369, #18713, and #16929 are all related to the scrollbar going
away due to a tree reflow, and then recieving events, probably all mouseups.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → DUPLICATE
After further investigation, I've decided that they're all really dupes of each
other.


*** This bug has been marked as a duplicate of 16929 ***
Status: RESOLVED → VERIFIED
Agreed. Marking as verified dup of 16929.
You need to log in before you can comment on or make changes to this bug.