when caption tag in table presented, td tag does not fire onmousedown event

RESOLVED DUPLICATE of bug 182499

Status

()

RESOLVED DUPLICATE of bug 182499
16 years ago
16 years ago

People

(Reporter: maros.ivanco, Assigned: saari)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021202
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021202

When caption tag in table presented, td tag does not fire onmousedown event. If
the mouse is down on the content (text) of the td tag, then the event is fired
properly. If the mouse is down on the td tag on the area without content (before
text), the event is not fired.

Reproducible: Always

Steps to Reproduce:
1.try example from Additional Informatinon
2. click to the different parts of td tag with text "something", note, that
event is fired only when mouse is down on the text.
3. remove caption tag from table
4. repeat ste 2. Note, that event is now fired every time.

Actual Results:  
Event is fired only when mouse is down on the text.

Expected Results:  
Event should be fired every time.

<?xml version='1.0' encoding="UTF-8" ?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
	<head>
		<title>test</title>
	</head>
	<body>
		<table border="1px" width="50%" >
			<caption>test</caption>
			<tbody>
				<tr onmousedown="alert('hula');"><td align="right">something</td></tr>
			</tbody>
		</table>
	</body>
</html>

Comment 1

16 years ago
Related to bug 182499?
Related like a twin sibling.

*** This bug has been marked as a duplicate of 182499 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.