The default bug view has changed. See this FAQ.

missing hotsync log entry on both PC and Palm to indicate Mozilla Address Book Sync

RESOLVED FIXED

Status

MailNews Core Graveyard
Palm Sync
--
major
RESOLVED FIXED
15 years ago
8 years ago

People

(Reporter: Stew Feuerstein, Assigned: wsmwk)

Tracking

({fixed1.8.1.4})

Trunk
fixed1.8.1.4

Details

Attachments

(1 attachment, 6 obsolete attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2.1) Gecko/20021130

I finally got Address Sync to work, after updating the registry.  I am using
Palm Hotsync 4.1 .  After hot synching if you click on 'view log' either on the
palm or in the Hotsync PC software, there is no indication that a Mozilla
Address Book hotsync occured.  Other conduits put a message in both like
Avantgo's 'OK Mobile Application Link' or Palm's 'OK Notepad'.

Reproducible: Always

Steps to Reproduce:
1.  Hotsync
2.  Click on 'log' radio button on Palm or right click on Hotsync Icon in PC
system tray and select 'view log'.


Actual Results:  
Only messages from other conduits.

Expected Results:  
added a message to the log similar to:
OK Mozilla Address Book

Updated

15 years ago
QA Contact: meehansqa → nbaca

Comment 1

14 years ago
I can confirm this as well.  Although the Palm (Handspring Visor in
my case) reports the synchronization on the screen, there is no
report in the log.

Comment 2

14 years ago
Nominating because viewing a HotSync Log and expecting the Mozilla Address Book
to be listed is expected.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: nsbeta1

Comment 3

14 years ago
Mail triage team: nsbeta1+/adt3
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt3]

Comment 4

14 years ago
-> cavin
Assignee: rdayal → cavin

Updated

14 years ago
Target Milestone: --- → mozilla1.4alpha

Updated

14 years ago
Target Milestone: mozilla1.4alpha → mozilla1.4beta

Comment 5

14 years ago
Created attachment 123186 [details] [diff] [review]
Draft, not a patch yet.

It creates the following entry in the PC HotSync manager's log (ie, click 'View
Log' to see the log):

   OK MozABConduit

Right now GetConduitName() returns a hard coded name "MozABConduit", so still
need to fix this. Also need to figure out how to add a log entry to the
handheld side.

Comment 6

14 years ago
Created attachment 123198 [details] [diff] [review]
Draft, not a patch yet.

This one creates log entries on the handheld as well. Still need to resolve a
better conduit name.
Attachment #123186 - Attachment is obsolete: true
Product: MailNews → Core
(Assignee)

Comment 7

12 years ago
is the patch still valid?
Assignee: cavin → nobody
Severity: enhancement → normal
Keywords: helpwanted
OS: Windows NT → All
QA Contact: nbaca
Hardware: PC → All
Summary: Palm hotsync log on both PC and Palm do not indicate that a Mozilla Address Book Sync took place. → missing hotsync log entry on both PC and Palm to indicate Mozilla Address Book Sync
Whiteboard: [adt3]
Target Milestone: mozilla1.4beta → ---

Comment 8

12 years ago
Concerning hotsync address base I can confirm the bug - there is no 
confirmation of the hot sync process in the log (f.example "OK mozilla address 
book") - it does not appear in the log.

(Palm 5, W2k SP4/ 5 ...)

Comment 9

12 years ago
I can confirm this bug ;-( ; about 30 entries are missing, too.

Comment 10

12 years ago
I can confirm this bug ;-( ; about 30 entries are missing, too.
(Palm 5, W2k SP4/5...)
(Assignee)

Comment 11

12 years ago
Example log...

HotSync operation started 10/12/05 07:51:28
OK Install
OK Date Book
OK To Do List
OK Memo Pad
OK Expense
[we should see "OK Mozilla Address Book"]
...
OK System
HotSync operation complete 10/12/05 07:54:37
(Assignee)

Comment 12

12 years ago
Comment on attachment 123198 [details] [diff] [review]
Draft, not a patch yet.

David, looks good except need better conduit name for the log as noted in
comments 6 & 7. what do you think?  Note patch is is for the hotsync log, not
the optional PC conduit log.
Attachment #123198 - Flags: review?(bienvenu)

Comment 13

12 years ago
Comment on attachment 123198 [details] [diff] [review]
Draft, not a patch yet.

I'll try this out. Thx for the patch.
(Assignee)

Comment 14

11 years ago
(In reply to comment #13)
> (From update of attachment 123198 [details] [diff] [review] [edit])
> I'll try this out. Thx for the patch.

David, can we land the patch and get it tested?
Then do a second patch to improve the name (eg "Mozilla Address Book").
Severity: normal → major
Keywords: helpwanted
(Assignee)

Comment 15

10 years ago
(In reply to comment #13)
> (From update of attachment 123198 [details] [diff] [review])
> I'll try this out. Thx for the patch.

David, can you hook me up with an extension built against TB 2.0 with this patch?
Status: NEW → ASSIGNED

Comment 16

10 years ago
I don't think I'm set up to build the extension anymore - I don't have the latest palm SDK (though I'm not sure that's required or not...)
(Assignee)

Comment 17

10 years ago
Comment on attachment 123198 [details] [diff] [review]
Draft, not a patch yet.

obsolete - might have been good 11 versions ago

interesting find - according to palm conduit documentation "Note that HotSync Manager automatically logs the general success or failure status of your conduit; therefore you need not add an entry for this purpose."

Don't know if that's true and if so why it's not doing that. Anyway, revised patch coming up.
Attachment #123198 - Attachment is obsolete: true
Attachment #123198 - Flags: review?(bienvenu)
(Assignee)

Comment 18

10 years ago
Created attachment 258069 [details] [diff] [review]
Add HSM log entry v1

Includes flag to HSM that conduit is finished syncing.
Assignee: nobody → vseerror
Attachment #258069 - Flags: superreview?(bienvenu)
Attachment #258069 - Flags: review?(bienvenu)
(Assignee)

Comment 19

10 years ago
David, is the build system still using CDK 4.03? Or is it the newer 6.01?

Comment 20

10 years ago
4.03 - I couldn't get the conduit to compile with 6.01, at least on the 2.0 branch.
(Assignee)

Updated

10 years ago
Attachment #258069 - Flags: superreview?(bienvenu)
Attachment #258069 - Flags: superreview?
Attachment #258069 - Flags: review?(bienvenu)
Attachment #258069 - Flags: review?
(Assignee)

Comment 21

10 years ago
Created attachment 258366 [details] [diff] [review]
Add HSM log entry v2

David here's v2 for respin of extension
Attachment #258069 - Attachment is obsolete: true
Attachment #258069 - Flags: superreview?
Attachment #258069 - Flags: review?
(Assignee)

Comment 22

10 years ago
Created attachment 260316 [details] [diff] [review]
Add HSM log entry v3 (contains bad file name)

logs to HSM (and conduit log) at beginning and end of sync.

for slSyncFinished I removed "without errors" from the message because I'm not convinced yet that retval=0 can be completely trusted to indicate the sync finished without error.

David, please e-mail me the resulting XPI. Thanks.
Attachment #258366 - Attachment is obsolete: true
(Assignee)

Updated

10 years ago
Attachment #260316 - Attachment is patch: true
(Assignee)

Updated

10 years ago
Attachment #260316 - Attachment description: Add HSM log entry v3 → Add HSM log entry v3 (contains bad file name)
Attachment #260316 - Attachment is obsolete: true
(Assignee)

Comment 23

10 years ago
Created attachment 260334 [details] [diff] [review]
Add HSM log entry v3

fix file name in patch
(Assignee)

Comment 24

10 years ago
Created attachment 261210 [details] [diff] [review]
Add HSM log entry v4

move start and end log entries to more completely bracket the code. add new line on starting entry. That should do it.
Attachment #260334 - Attachment is obsolete: true
(Assignee)

Comment 25

10 years ago
David, please commit patch v4 to trunk and branch. Thanks
(Assignee)

Comment 26

10 years ago
Comment on attachment 261210 [details] [diff] [review]
Add HSM log entry v4

desired on branch to improve debugging of palmsync conduit starting with TB 2.
Attachment #261210 - Flags: superreview?(bienvenu)
Attachment #261210 - Flags: review?(bienvenu)
Attachment #261210 - Flags: approval1.8.1.4?
Comment on attachment 261210 [details] [diff] [review]
Add HSM log entry v4

Please get reviews before requesting branch approval.
Attachment #261210 - Flags: approval1.8.1.4?
(Assignee)

Comment 28

10 years ago
attachment 261210 [details] [diff] [review] patch worked without problems for at least three testers. 

Comment 29

10 years ago
Comment on attachment 261210 [details] [diff] [review]
Add HSM log entry v4

fix checked into the trunk and 2.0 branch, thx, Wayne!
Attachment #261210 - Flags: superreview?(bienvenu)
Attachment #261210 - Flags: superreview+
Attachment #261210 - Flags: review?(bienvenu)
Attachment #261210 - Flags: review+

Comment 30

10 years ago
marking fixed, and adding keyword (even though it's not really part of the build)
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: fixed1.8.1.4
Resolution: --- → FIXED
(Assignee)

Comment 31

10 years ago
wanted on branch to issue updated palmsync extension conduit for TB 2.  Only affects conduit modules. Does not touch thunderbird or core modules.
Flags: blocking1.8.1.4?

Comment 32

10 years ago
clearing blocking request - I already landed this on the branch, since it's not part of the build.

Updated

9 years ago
Flags: blocking1.8.1.4?
Product: Core → MailNews Core

Updated

8 years ago
Component: Palm Sync → Palm Sync
Product: MailNews Core → MailNews Core Graveyard
You need to log in before you can comment on or make changes to this bug.