Closed Bug 1837624 Opened 1 year ago Closed 1 month ago

Address bar with selected search engine: ? at start of search term is ignored

Categories

(Firefox :: Address Bar, defect, P3)

Firefox 114
Desktop
All
defect

Tracking

()

VERIFIED FIXED
127 Branch
Tracking Status
firefox116 --- wontfix
firefox117 --- wontfix
firefox118 --- wontfix
firefox127 --- verified
firefox128 --- verified

People

(Reporter: gilward.kukel, Assigned: mcheang)

References

Details

(Whiteboard: [sng-scrubbed][search-papercut])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/114.0

Steps to reproduce:

Select search engine in address bar, e.g. Google.
Type ?qwe.
Press Enter.

Actual results:

Google searches for "qwe".

Expected results:

Google should search for "?qwe".

And when the search term starts with ? and a space, they are removed and the default search engine is selected.

The Bugbug bot thinks this bug should belong to the 'Firefox::Address Bar' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Address Bar

The severity field is not set for this bug.
:adw, could you have a look please?

For more information, please visit BugBot documentation.

Flags: needinfo?(adw)

What's your use case to search for "?something"?

This is actually working by design, because for the Address Bar the question mark is a special character limiting the search to only Search Suggestions from the default engine. https://bugzilla.mozilla.org/show_bug.cgi?id=1545336 is related as it will require to add a space after restriction tokens, but we're not yet sure whether it will be done for the question mark.

Flags: needinfo?(adw) → needinfo?(gilward.kukel)

Hello! I have managed to reproduce the issue with firefox 118.0a1(2023-08-17), 117.0b8 and 106.0.2 on Windows 10 and Ubuntu 22.04.
I will mark this issue as NEW in order to get our developers involved and set the corresponding flags accordingly.

Have a nice day!

Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → Desktop

Indeed while using search mode, we shouldn't be stripping the restriction token (?). So this is indeed a bug.

Severity: -- → S3
Priority: -- → P3
Whiteboard: [sng-scrubbed][search-papercut]
Flags: needinfo?(gilward.kukel)
Assignee: nobody → mcheang
Status: NEW → ASSIGNED
Attachment #9400372 - Attachment description: Bug 1837624 - When user are in search mode, the symbol ? at the beginning should not be marked as restrict token. r=mak → Bug 1837624 - When a user is in search mode, the symbol ? at the beginning of the search string should not be marked as restrict token. r=mak
Pushed by mcheang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/27b22407ab5b
When a user is in search mode, the symbol ? at the beginning of the search string should not be marked as restrict token. r=mak
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 127 Branch

Reproducible on a 2024-05-05 Nightly build on Windows 10.
Verified as fixed on Firefox Nightly 128.0a1 and Firefox 127.0b1 on Windows 10, macOS 12, Ubuntu 22.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: