Closed Bug 1838364 Opened 9 months ago Closed 9 months ago

incorrect property is displayed as active with !important

Categories

(DevTools :: Inspector: Rules, defect)

Firefox 99
defect

Tracking

(firefox-esr102 wontfix, firefox114 wontfix, firefox115 verified, firefox116 verified)

VERIFIED FIXED
116 Branch
Tracking Status
firefox-esr102 --- wontfix
firefox114 --- wontfix
firefox115 --- verified
firefox116 --- verified

People

(Reporter: 6k64x4ma, Assigned: jdescottes)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached file test.html

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/115.0

Steps to reproduce:

This may be a duplicate of bug 1824652

  1. Load the attached file.
  2. Open the inspector, select the div.

Actual results:

In the rule view, the color: red; is the one that is tagged as active

Expected results:

In the rule view, the color: green !important is the one that is tagged as active

regression window:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=950c1613c97dc8cb5191c6497224193470de631d&tochange=d0676cb0864b870062fed21bc900d6fbb3cf5670
I think bug 1753196 is suspicious.

Keywords: regression
Regressed by: 1753196
See Also: → 1824652

:jdescottes, since you are the author of the regressor, bug 1753196, could you take a look? Also, could you set the severity field?

For more information, please visit BugBot documentation.

Flags: needinfo?(jdescottes)

Ah good catch, thanks for filing!

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(jdescottes)
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED

Set release status flags based on info from the regressing bug 1753196

Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/933dd3c3e1c8
[devtools] Show override for !important rules on the same inherited node r=devtools-reviewers,nchevobbe
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 116 Branch

The patch landed in nightly and beta is affected.
:jdescottes, is this bug important enough to require an uplift?

  • If yes, please nominate the patch for beta approval.
  • If no, please set status-firefox115 to wontfix.

For more information, please visit BugBot documentation.

Flags: needinfo?(jdescottes)

Comment on attachment 9339011 [details]
Bug 1838364 - [devtools] Show override for !important rules on the same inherited node

Beta/Release Uplift Approval Request

  • User impact if declined: The rule view displays incorrect information in some situations where rules are using the !important keyword. This is a relatively old regression, but it should be really a straightforward uplift.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small JS change, covered by browser mochitests.
  • String changes made/needed:
  • Is Android affected?: No
Flags: needinfo?(jdescottes)
Attachment #9339011 - Flags: approval-mozilla-beta?

Comment on attachment 9339011 [details]
Bug 1838364 - [devtools] Show override for !important rules on the same inherited node

Approved for 115.0b6.

Attachment #9339011 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

I have managed to reproduce the issue using Firefox 114.0.1 (20230608214645) on MacOS 11, Windows 10, Ubuntu 20.04 and verified the fix using Firefox Beta 115.0b6 (20230615175802) and Firefox Nightly 116.0a1 (20230615214334).

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.