Closed Bug 1838664 Opened 1 year ago Closed 11 months ago

Implement "browsingContext.setViewport" command

Categories

(Remote Protocol :: WebDriver BiDi, task, P1)

task
Points:
3

Tracking

(firefox117 fixed)

RESOLVED FIXED
117 Branch
Tracking Status
firefox117 --- fixed

People

(Reporter: whimboo, Assigned: whimboo)

References

(Blocks 3 open bugs, )

Details

(Whiteboard: [webdriver:m8], [wptsync upstream] [webdriver:relnote])

Attachments

(2 files, 1 obsolete file)

The browsingContext.setViewport command will allow clients to adjust the size of the visible viewport.

As of now it is not available in the specification but should get merged soon.

Type: enhancement → task

The PR got merged and we basically could get started with the implementation. But I would suggest we are waiting for at least the tests Alex is currently working on. The first PR can be found at https://github.com/web-platform-tests/wpt/pull/40584.

Priority: -- → P2
Whiteboard: [webdriver:m7]

I have started to implement this command yesterday and it was not that difficult given that most of the CDP code was already written. While testing I actually noticed a bug in CDP, which we should fix as a follow-up once the BiDi support has been landed.

Assignee: nobody → hskupin
Status: NEW → ASSIGNED
Priority: P2 → P1
Points: --- → 2

I'm going to wait until the Webdriver tests are merged and synced to mozilla-central. There are a couple of enhancements that I would like to do for a better coverage.

Depends on: 1838823
Points: 2 → 3
Whiteboard: [webdriver:m7] → [webdriver:m8]

Already existing tests on the wpt repository which haven't downstreamed yet.

The patches are fully reviewed and only waiting for the next downstream sync.

Julian, could you please take care of the following while I'm away?

  • Abandoning the first revision because it's not needed once Alex' tests are available
  • Rebasing the patches including fixes for the merge conflicts mainly for the wpt manifest files
  • Landing the patch

Thanks!

Flags: needinfo?(jdescottes)
Attachment #9342721 - Attachment is obsolete: true

pushed to lando

Flags: needinfo?(jdescottes)
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bcdece3e8f97
[webdriver-bidi] Implement "browsingContext.setViewport" command. r=webdriver-reviewers,jdescottes
https://hg.mozilla.org/integration/autoland/rev/238a99a8900a
[wdspec] Enhanced tests for browsingContext.setViewport. r=webdriver-reviewers,jdescottes
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/41014 for changes under testing/web-platform/tests
Whiteboard: [webdriver:m8] → [webdriver:m8], [wptsync upstream]
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 117 Branch
Upstream PR merged by moz-wptsync-bot
Regressions: 1843604
Whiteboard: [webdriver:m8], [wptsync upstream] → [webdriver:m8], [wptsync upstream] [webdriver:relnote]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: