Closed Bug 1839650 Opened 1 year ago Closed 1 year ago

Update migration automated tests to test the extensions resource with the InternalTestingProfileMigrator

Categories

(Firefox :: Migration, task, P1)

task

Tracking

()

RESOLVED FIXED
116 Branch
Tracking Status
firefox116 --- fixed

People

(Reporter: mconley, Assigned: mconley)

References

(Blocks 1 open bug, Regressed 1 open bug)

Details

Attachments

(2 files)

The browser_do_migration.js test intentionally skips testing the extensions resource for now because the testing infrastructure needs to be taught how to test the ending result of importing extensions. This task is to get those tests written.

Severity: -- → N/A
Priority: -- → P3
Assignee: nobody → mconley
Priority: P3 → P1
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/397a3150e68c
Update browser_do_migration test to test extensions resource migration. r=niklas
https://hg.mozilla.org/integration/autoland/rev/da38525a017e
Add more extension migration tests. r=niklas

Backed out for causing mochitest-chrome failures on test_history.html.

Flags: needinfo?(mconley)
Pushed by imoraru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/482b2f054ce2
Update browser_do_migration test to test extensions resource migration. r=niklas
https://hg.mozilla.org/integration/autoland/rev/80adb872a3d1
Add more extension migration tests. r=niklas a=reland CLOSED TREE

Hi Mike! I have re-landed this. The reason for the backout were some backfills that pointed at your push as the culprit, but that was actually wrong, because there was a strange interaction when backfills combined with retriggers would pull dependencies from the wrong push.

Sorry for any inconvenience caused by this.
Thank you!

Thanks for relanding!

Flags: needinfo?(mconley)
Regressions: 1840718
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 116 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: