Wrong filetype (.tar) added to filename in download dialog.

RESOLVED DUPLICATE of bug 144334

Status

SeaMonkey
Download & File Handling
RESOLVED DUPLICATE of bug 144334
16 years ago
14 years ago

People

(Reporter: Martin Miller, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

When I click on the "Python-2.2.2.tgz" link on the web page (just before the
"What's New?" section). A dialog box pops up titled "Downloading
Python-2.2.2.tgz.tar" giving me the choice of opening the file with WinZip or
saving it to disk. The first thing to notice is the ".tar" added to filename on
the dialog box title. If I click on "save this file to disk" and click OK,
another dialog box appears titled "Enter name of file to save to...". Again the
filename automatically entered has had a ".tar" added to it. This is incorrect,
the filename should just be "Python-2.2.2.tgz" NOT "Python-2.2.2.tgz.tar".

This does not happen if I download the file using FTP by clicking on the link at
the very bottom of the page that ends with "ALl the above file can be found via
FTP, too."

I tried the same web page in old NS v4.79 and did not encounter this problem.


Reproducible: Always

Steps to Reproduce:
1. see details above
2.
3.

Actual Results:  
see details above

Expected Results:  
No bogus extension appended to filename.

There's an easy workaround, just delete the appended extension. However, I don't
think it's minor. Many people won't notice or figure out what's going wrong
until later, if ever.

In my case I didn't notice until I tried to open the file myself with WinZip and
got an error message. I went to the trouble of sending WinZip an error report
and re-download the rather large file several times before I noticed what was
going on.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 144334 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.