Closed Bug 1840724 Opened 1 year ago Closed 1 year ago

Neither <datalist> nor its <option>s are exposed in Firefox for Android

Categories

(Core :: DOM: Forms, defect)

Firefox 114
Unspecified
Android
defect

Tracking

()

RESOLVED DUPLICATE of bug 1535985

People

(Reporter: aroselli, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/114.0
Firefox for Android

Steps to reproduce:

Using Firefox 114 on a Pixel 6 running Android 13 and TalkBack 13.1:

  1. Go to https://cdpn.io/aardrian/debug/RwqKJZz
  2. Put focus in the field labeled "Berries" (or "Datalist")
  3. Observe no list of options appears anywhere
  4. Start to enter a value
  5. Observe no list of options appears anywhere, and note that any autocomplete suggestions above the keyboard are not related to the options
  6. Activate TalkBack
  7. Observe the field is announced as a plain text field ("Edit box... double tap to edit text")
  8. Observe no announcements of options being available

Actual results:

At no point was I presented with the list of options from the <datalist>. Not alongside the field, not as suggestions, nowhere.

Expected results:

options from the <datalist> should be exposed to users in some way.

The Bugbug bot thinks this bug should belong to the 'Core::Disability Access APIs' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Disability Access APIs
Product: Firefox → Core
Component: Disability Access APIs → DOM: Forms
OS: Unspecified → Android

I changed the component to 'DOM: Forms' since the feature appears to be exposed to nobody. Me using TalkBack was confirming that is not programmatically exposed even in the absence of a visual interface. But this is not my rodeo, so change as you see fit.

I asked on the socials for folks to confirm what I was experiencing (I don't have a testing team)...

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Duplicate of bug: 1535985
Resolution: --- → DUPLICATE

Thanks. I really did search before posting.

You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: