Closed Bug 1841167 Opened 11 months ago Closed 7 months ago

SeaMonkey Branding Cleanup

Categories

(SeaMonkey :: General, enhancement)

enhancement

Tracking

(seamonkey2.53+ fixed)

RESOLVED FIXED
Tracking Status
seamonkey2.53 + fixed

People

(Reporter: frg, Assigned: frg)

Details

(Whiteboard: SM2.53.18)

Attachments

(3 files, 1 obsolete file)

We still have a few wrong trademark strings in our code which need to be switched to SeaMonkey e.V.

The default bookmarks also have a Mozilla related item in. Since we are no longer a Mozilla project we should not give the impression that there is still a connection between us and them. Further cleanup on the Website needed but lets start with the code.

Attached patch 1841167-branding-25318.patch (obsolete) — Splinter Review

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: Wrong legal information
Testing completed (on m-c, etc.): 2.53.18b1 pre
Risk to taking this patch (and alternatives if risky): trivial changes.
String changes made by this patch: see bookmarks.inc

Strings in bookmarks.inc seem not to be picked up for translation so define a dummy file additionalValues.properties in branding.

Attachment #9341824 - Flags: review?(iannbugzilla)
Attachment #9341824 - Flags: approval-comm-release?

(In reply to Frank-Rainer Grahl (:frg) from comment #1)

Created attachment 9341824 [details] [diff] [review]
1841167-branding-25318.patch

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: Wrong legal information
Testing completed (on m-c, etc.): 2.53.18b1 pre
Risk to taking this patch (and alternatives if risky): trivial changes.
String changes made by this patch: see bookmarks.inc

Strings in bookmarks.inc seem not to be picked up for translation so define a dummy file additionalValues.properties in branding.

When I do mach build installers-<locale> it seems to pick up bookmarks.inc fine for me

Flags: needinfo?(frgrahl)

I am pretty much sure a missing translation in bookmarks.inc will not show up in Pontoon but may be wrong. If everything else is ok and you r/a+ I will split this part and not check it in. If it does not show up then I will push it separately for later removal after Pontoon access is gone.

Flags: needinfo?(frgrahl)

Seems Pontoon is picking up bookmarks.inc after all.

Attachment #9341824 - Attachment is obsolete: true
Attachment #9341824 - Flags: review?(iannbugzilla)
Attachment #9341824 - Flags: approval-comm-release?
Attachment #9342050 - Flags: review?(iannbugzilla)
Attachment #9342050 - Flags: approval-comm-release?

Comment on attachment 9342050 [details] [diff] [review]
1841167-branding-1_1-25318.patch

[Triage Comment]
LGTM r/a=me

Attachment #9342050 - Flags: review?(iannbugzilla)
Attachment #9342050 - Flags: review+
Attachment #9342050 - Flags: approval-comm-release?
Attachment #9342050 - Flags: approval-comm-release+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/084d5ce463ff
Clean up branding files. r=IanN

Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: Wrong vendor information in Windows programm install details.
Testing completed (on m-c, etc.): 2.53.19b1 pre
Risk to taking this patch (and alternatives if risky): trivial.
String changes made by this patch: hardcoded branding strings only.

Attachment #9360895 - Flags: review?(iannbugzilla)
Attachment #9360895 - Flags: approval-comm-release?
Attached image Windows install details
Comment on attachment 9360895 [details] [diff] [review]
1841167-2-fixbranding-25318.patch

Review of attachment 9360895 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM r/a=me
Attachment #9360895 - Flags: review?(iannbugzilla)
Attachment #9360895 - Flags: review+
Attachment #9360895 - Flags: approval-comm-release?
Attachment #9360895 - Flags: approval-comm-release+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/c7d927f15aee
Change company info and url in nsis installer. r=IanN

Status: REOPENED → RESOLVED
Closed: 11 months ago7 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: